package/usb_modeswitch: disable parallel build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 22 Nov 2018 18:07:46 +0000 (19:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 24 Nov 2018 12:03:23 +0000 (13:03 +0100)
Build of package will sometime fails because of the following issue:
install-static target has two dependencies: dispatcher-static and
install-common

Because dispatcher-static is not a file but only a target, it will
always be called to build usb_modeswitch_dispatcher.
So, even if install-common depends on usb_modeswitch_dispatcher, in some
rare cases, install-static won't be able to install
usb_modeswitch_dispatcher because it is being rebuild by
dispatcher-static

To fix this issue, disable parallel build

Fixes:
 - http://autobuild.buildroot.org/results/8297be35725b816ff5afaf909605ceb41223efb6

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/usb_modeswitch/usb_modeswitch.mk

index d0c33cc187154ff62c6c28d3ae5c9021b6e73cd6..bb0d6ab1bf3c770a33148077425d7d54e49d95bf 100644 (file)
@@ -10,6 +10,8 @@ USB_MODESWITCH_SITE = http://www.draisberghof.de/usb_modeswitch
 USB_MODESWITCH_DEPENDENCIES = libusb
 USB_MODESWITCH_LICENSE = GPL-2.0+
 USB_MODESWITCH_LICENSE_FILES = COPYING
+# Package does not build in parallel due to improper make rules
+USB_MODESWITCH_MAKE = $(MAKE1)
 
 USB_MODESWITCH_BUILD_TARGETS = static
 USB_MODESWITCH_INSTALL_TARGETS = install-static