systemd: disable ldconfig through configure option
authorGabe Evans <gabe@hashrabbit.co>
Tue, 3 Nov 2015 22:24:30 +0000 (22:24 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 3 Nov 2015 22:46:39 +0000 (23:46 +0100)
Systemd v216+ includes a configure option to disable ldconfig.

Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/systemd.mk

index 414dc0ded3cf95073cf5d615589dfc1fcf5002f6..35dac832a5cad778dbd7308c22e491521c1eeb66 100644 (file)
@@ -37,6 +37,7 @@ SYSTEMD_CONF_OPTS += \
        --with-dbussystemservicedir=/usr/share/dbus-1/system-services \
        --disable-efi \
        --disable-gnuefi \
+       --disable-ldconfig \
        --disable-tests \
        --disable-dbus \
        --without-python
@@ -154,17 +155,10 @@ define SYSTEMD_SANITIZE_PATH_IN_UNITS
                -exec $(SED) 's,$(HOST_DIR),,g' {} \;
 endef
 
-# Disable ldconfig.service, as /sbin/ldconfig is not available when the
-# target is built with a glibc-based toolchain.
-define SYSTEMD_DISABLE_LDCONFIG_SERVICE_HOOK
-       rm -f $(TARGET_DIR)/lib/systemd/system/sysinit.target.wants/ldconfig.service
-endef
-
 SYSTEMD_POST_INSTALL_TARGET_HOOKS += \
        SYSTEMD_INSTALL_INIT_HOOK \
        SYSTEMD_INSTALL_MACHINEID_HOOK \
        SYSTEMD_INSTALL_RESOLVCONF_HOOK \
-       SYSTEMD_DISABLE_LDCONFIG_SERVICE_HOOK \
        SYSTEMD_SANITIZE_PATH_IN_UNITS
 
 define SYSTEMD_USERS