package/mpd: add libmodplug optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 14 Aug 2020 21:19:38 +0000 (23:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 18 Aug 2020 21:49:08 +0000 (23:49 +0200)
libmodplug is an optional dependency since version 0.15.0 and
https://github.com/MusicPlayerDaemon/MPD/commit/d838a1ad24a9eaac44367e34506373b4b71e4ff0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpd/Config.in
package/mpd/mpd.mk

index baaaa7f1aea306e6b92e8f51618933222e93f334..eb4c28617e7199a8a0fcda2e7dd1412b39d9d4ed 100644 (file)
@@ -140,6 +140,12 @@ config BR2_PACKAGE_MPD_MAD
          Enable mad input support.
          Select this if you want to play back MP3 files.
 
+config BR2_PACKAGE_MPD_MODPLUG
+       bool "modplug"
+       select BR2_PACKAGE_LIBMODPLUG
+       help
+         Enable Modplug decoder support.
+
 config BR2_PACKAGE_MPD_MPG123
        bool "mpg123"
        select BR2_PACKAGE_LIBID3TAG
index 51bc1719a70d51cbe97ec17b99485c87a4a1f159..5e66997b2668c52fff2e3dddd70e7e4b9f967529 100644 (file)
@@ -180,6 +180,13 @@ else
 MPD_CONF_OPTS += -Dmad=disabled
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_MODPLUG),y)
+MPD_DEPENDENCIES += libmodplug
+MPD_CONF_OPTS += -Dmodplug=enabled
+else
+MPD_CONF_OPTS += -Dmodplug=disabled
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_MPG123),y)
 MPD_DEPENDENCIES += libid3tag mpg123
 MPD_CONF_OPTS += -Dmpg123=enabled