tinyxml2: fix build in static libs configuration
authorRahul Bedarkar <rahulbedarkar89@gmail.com>
Wed, 3 May 2017 19:04:14 +0000 (00:34 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 4 May 2017 15:08:41 +0000 (17:08 +0200)
tinyxml2 can build both static and shared libraries. By default, only
shared library is built. Shared/static builds are controlled using
separate cmake flags BUILD_SHARED_LIBS and BUILD_STATIC_LIBS.

In static libs configuration, we internally pass -DBUILD_SHARED_LIBS=OFF
cmake flag to build system which disables both shared and static builds
of library, resulting in failures while linking executable with library.

So pass -DBUILD_STATIC_LIBS=ON cmake flag in case of static libs
configuration.

fixes:
  http://autobuild.buildroot.net/results/d30/d301bcbe5db26068b35eaa94bd816ae8cf8ef2e1

Signed-off-by: Rahul Bedarkar <rahulbedarkar89@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tinyxml2/tinyxml2.mk

index bb1e16776f3b8f97f7f6089ef6f0c812801cb3e9..e289ca9cf082095db3e5e62ffe64d75e5d209252 100644 (file)
@@ -10,4 +10,8 @@ TINYXML2_LICENSE = Zlib
 TINYXML2_LICENSE_FILES = readme.md
 TINYXML2_INSTALL_STAGING = YES
 
+ifeq ($(BR2_STATIC_LIBS),y)
+TINYXML2_CONF_OPTS += -DBUILD_STATIC_LIBS=ON
+endif
+
 $(eval $(cmake-package))