.gitlab-ci.yml: extend check-package test to hash files
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Dec 2017 13:16:57 +0000 (14:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Dec 2017 13:16:57 +0000 (14:16 +0100)
Now that all issues in hash files have been fixed, let's try to make
sure we don't introduce new ones by checking regularly the hash files
issues in Gitlab CI.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
.gitlab-ci.yml
.gitlab-ci.yml.in

index a6540d1fda33799ec447869d7756078038eb1a76..dc7fd846eda3287e16ab35f3fa1f3fc818f5046a 100644 (file)
@@ -32,7 +32,7 @@ check-DEVELOPERS:
 
 check-package:
     script:
-        - find . -type f -name '*.mk' -exec ./utils/check-package {} +
+        - find . -type f \( -name '*.mk' -o -name '*.hash' \) -exec ./utils/check-package {} +
 
 .defconfig: &defconfig
     # Running the defconfigs for every push is too much, so limit to
index 0d2e239414e7a48dfb2f166117a18862d42c9e84..9a1e7a1e34b3db47b11e9b2e25b9d9b5909ef8e3 100644 (file)
@@ -32,7 +32,7 @@ check-DEVELOPERS:
 
 check-package:
     script:
-        - find . -type f -name '*.mk' -exec ./utils/check-package {} +
+        - find . -type f \( -name '*.mk' -o -name '*.hash' \) -exec ./utils/check-package {} +
 
 .defconfig: &defconfig
     # Running the defconfigs for every push is too much, so limit to