package/dropbear: install dropbear.service to correct dir
authorMaxim Mikityanskiy <maxtram95@gmail.com>
Mon, 19 Jan 2015 16:14:07 +0000 (18:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 23 Feb 2015 11:38:12 +0000 (12:38 +0100)
The place for package-provided systemd units is /lib/systemd/system.
/etc/systemd/system is for custom units.
Reviewed-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dropbear/dropbear.mk

index e063b10a46a3547233345b8567895b4d5204b9e8..f2ae4037b01bbb14689f0e31a31f5cc73384aa50 100644 (file)
@@ -53,9 +53,9 @@ endef
 
 define DROPBEAR_INSTALL_INIT_SYSTEMD
        $(INSTALL) -D -m 644 package/dropbear/dropbear.service \
-               $(TARGET_DIR)/etc/systemd/system/dropbear.service
+               $(TARGET_DIR)/lib/systemd/system/dropbear.service
        mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
-       ln -fs ../dropbear.service \
+       ln -fs /lib/systemd/system/dropbear.service \
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/dropbear.service
 endef