package/s390-tools: add zlib dependency
authorAlexander Egorenkov <egorenar@linux.ibm.com>
Tue, 20 Oct 2020 10:39:04 +0000 (12:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 24 Oct 2020 20:54:45 +0000 (22:54 +0200)
zlib is required to build s390-tools and cannot be disabled for now
due to libvmdump.

Fixes:

$BUILD_DIR/host/bin/s390x-buildroot-linux-gnu-g++ ... -c vmdump_convert.cpp -o vmdump_convert.o
lkcd_dump.cpp:15:10: fatal error: zlib.h: No such file or directory
   15 | #include <zlib.h>
      |          ^~~~~~~~
compilation terminated.

Signed-off-by: Alexander Egorenkov <egorenar@linux.ibm.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/s390-tools/Config.in
package/s390-tools/s390-tools.mk

index a553b5eeab85a80fe8a3334991e9e0c9ba5c91d8..4aede4e2652df9fe00e8c404ff1dc341c3a52334 100644 (file)
@@ -7,6 +7,7 @@ config BR2_PACKAGE_S390_TOOLS
        depends on BR2_s390x
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_USES_GLIBC
+       select BR2_PACKAGE_ZLIB
        help
          Tools for use with the s390 Linux kernel and device drivers.
 
index 4d4c8188feb1834cec41d5dfbcb77ea5f10c02d2..d186f85cd318b3145368361c9debbf245e388130 100644 (file)
@@ -8,6 +8,7 @@ S390_TOOLS_VERSION = 2.14.0
 S390_TOOLS_SITE = $(call github,ibm-s390-tools,s390-tools,v$(S390_TOOLS_VERSION))
 S390_TOOLS_LICENSE = MIT
 S390_TOOLS_LICENSE_FILES = LICENSE
+S390_TOOLS_DEPENDENCIES = zlib
 
 S390_TOOLS_MAKE_OPTS = \
        ARCH=$(BR2_ARCH) \