pptp-linux: fix parallel build
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 3 Feb 2013 20:53:21 +0000 (21:53 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 Feb 2013 07:02:22 +0000 (08:02 +0100)
Add a patch to fix a parallel build issue caused by a header file
being generated too late.

Fixes:

http://autobuild.buildroot.org/results/2324974d4818b2657a7df4beee33fc4713d6116f/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pptp-linux/pptp-linux-004-fix-parallel-build.patch [new file with mode: 0644]

diff --git a/package/pptp-linux/pptp-linux-004-fix-parallel-build.patch b/package/pptp-linux/pptp-linux-004-fix-parallel-build.patch
new file mode 100644 (file)
index 0000000..04a7977
--- /dev/null
@@ -0,0 +1,23 @@
+Fix parallel build issue
+
+The config.h header file must be created before being used to build
+source files that include it, especially version.c. In order for this
+to happen even in highly-parallel builds, we add a dependency of all
+object files on config.h, in order to ensure it gets generated before
+make attempts to build the object files.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -37,6 +37,8 @@
+ all: config.h $(PPTP_BIN) pptpsetup.8
++$(PPTP_OBJS): config.h
++
+ $(PPTP_BIN): $(PPTP_OBJS) $(PPTP_DEPS)
+       $(CC) -o $(PPTP_BIN) $(PPTP_OBJS) $(LDFLAGS) $(LIBS)