rsyslog: enable journal plugins when using systemd
authorJames Knight <james.knight@rockwellcollins.com>
Tue, 20 Dec 2016 00:05:15 +0000 (19:05 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 20 Dec 2016 09:10:05 +0000 (10:10 +0100)
The rsyslog package provides input and output plugins for journald which
are disabled by default. The following adds the option to include
`imjournal` and `omjournal` modules when building for a systemd target.

Signed-off-by: James Knight <james.knight@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/rsyslog/rsyslog.mk

index 9e74e49dc86b030e9ff2c975c9a546dd51227943..3254d9993390787c1f08143cff8bc5b1838442da 100644 (file)
@@ -66,8 +66,14 @@ endif
 
 ifeq ($(BR2_INIT_SYSTEMD),y)
 RSYSLOG_CONF_OPTS += \
+       --enable-imjournal \
+       --enable-omjournal \
        --with-systemdsystemunitdir=/usr/lib/systemd/system
 RSYSLOG_DEPENDENCIES += systemd
+else
+RSYSLOG_CONF_OPTS += \
+       --disable-imjournal \
+       --disable-omjournal
 endif
 
 define RSYSLOG_INSTALL_INIT_SYSV