package/gstreamer1/gst1-plugins-base: add tools option
authorPeter Seiderer <ps.report@gmx.net>
Tue, 3 Mar 2020 16:47:02 +0000 (17:47 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 5 Mar 2020 22:26:53 +0000 (23:26 +0100)
Add tools option to disable building/installing of gst-discoverer,
gst-device-monitor and gst-play command line tools (similar to
BR2_PACKAGE_GSTREAMER1_INSTALL_TOOLS).

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-base/Config.in
package/gstreamer1/gst1-plugins-base/gst1-plugins-base.mk

index f60d5403371ac9b0b32b01c7c20ff7d1b5ad2c9b..db916ed219ea0af395e5740bedb66a944344abd6 100644 (file)
@@ -10,6 +10,12 @@ menuconfig BR2_PACKAGE_GST1_PLUGINS_BASE
 
 if BR2_PACKAGE_GST1_PLUGINS_BASE
 
+config BR2_PACKAGE_GST1_PLUGINS_BASE_INSTALL_TOOLS
+       bool "install tools"
+       help
+         Install the gst-discoverer, gst-device-monitor and gst-play
+         tools.
+
 comment "dependency-less plugins"
 
 config BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_ADDER
index 1781a5d461cb9cf0013683004b5326cdaba151d3..ccecbb3c08d1cbc4529d28710484088abebb4397 100644 (file)
@@ -26,6 +26,12 @@ GST1_PLUGINS_BASE_CONF_OPTS += \
        -Dlibvisual=disabled \
        -Diso-codes=disabled
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE_INSTALL_TOOLS),y)
+GST1_PLUGINS_BASE_CONF_OPTS += -Dtools=enabled
+else
+GST1_PLUGINS_BASE_CONF_OPTS += -Dtools=disabled
+endif
+
 GST1_PLUGINS_BASE_DEPENDENCIES = gstreamer1 $(TARGET_NLS_DEPENDENCIES)
 
 GST1_PLUGINS_BASE_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)