python-pysendfile: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Tue, 20 Jan 2015 20:38:55 +0000 (21:38 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 23 Jan 2015 20:17:25 +0000 (21:17 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-pysendfile/Config.in [new file with mode: 0644]
package/python-pysendfile/python-pysendfile.hash [new file with mode: 0644]
package/python-pysendfile/python-pysendfile.mk [new file with mode: 0644]

index 266de133c08a84b2518c73d14e695eff3d7ed7e3..32d675588dd76ab55bbcd2f49885706ac9f3b44d 100644 (file)
@@ -540,6 +540,7 @@ menu "external python modules"
        source "package/python-pyparsing/Config.in"
        source "package/python-pypcap/Config.in"
        source "package/python-pyro/Config.in"
+       source "package/python-pysendfile/Config.in"
        source "package/python-pysnmp/Config.in"
        source "package/python-pysnmp-apps/Config.in"
        source "package/python-pysnmp-mibs/Config.in"
diff --git a/package/python-pysendfile/Config.in b/package/python-pysendfile/Config.in
new file mode 100644 (file)
index 0000000..5a919dd
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_PYSENDFILE
+       bool "python-pysendfile"
+       help
+         A Python interface to sendfile(2) syscall
+
+         https://github.com/giampaolo/pysendfile
diff --git a/package/python-pysendfile/python-pysendfile.hash b/package/python-pysendfile/python-pysendfile.hash
new file mode 100644 (file)
index 0000000..755be50
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256  f4ca8a7f0be67e3d710c0633dd9aadab6881203c31cb9eb9be4f10361ad3f937  python-pysendfile-2.0.1.tar.gz
diff --git a/package/python-pysendfile/python-pysendfile.mk b/package/python-pysendfile/python-pysendfile.mk
new file mode 100644 (file)
index 0000000..bb8f057
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-pysendfile
+#
+################################################################################
+
+PYTHON_PYSENDFILE_VERSION = 2.0.1
+PYTHON_PYSENDFILE_SITE = $(call github,giampaolo,pysendfile,release-$(PYTHON_PYSENDFILE_VERSION))
+PYTHON_PYSENDFILE_SETUP_TYPE = setuptools
+PYTHON_PYSENDFILE_LICENSE = MIT
+PYTHON_PYSENDFILE_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))