python3: bump to version 3.4.1
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 8 Jul 2014 10:42:39 +0000 (12:42 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 8 Jul 2014 11:56:45 +0000 (13:56 +0200)
A few minor updates on the patches were needed to resolve some
conflicts on the main Makefile.pre.in file, in the list of modules to
build/install.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
15 files changed:
package/python3/python3-003-sysconfigdata-install-location.patch
package/python3/python3-006-cross-compile-getaddrinfo.patch
package/python3/python3-007-disable-extensions.patch
package/python3/python3-100-optional-test-modules.patch
package/python3/python3-101-optional-pydoc.patch
package/python3/python3-102-optional-2to3.patch
package/python3/python3-103-optional-sqlite.patch
package/python3/python3-104-optional-tk.patch
package/python3/python3-105-optional-curses.patch
package/python3/python3-106-optional-expat.patch
package/python3/python3-107-optional-codecs-cjk.patch
package/python3/python3-108-optional-nis.patch
package/python3/python3-109-optional-unicodedata.patch
package/python3/python3-110-optional-idle.patch
package/python3/python3.mk

index af796d48d591f7c997b25cafb9cbe299cfcad1f0..1f230d4b86edcb90f246f513aacec64fe9be775a 100644 (file)
@@ -52,7 +52,7 @@ Index: b/Makefile.pre.in
        @for d in $(LIBSUBDIRS); \
        do \
                a=$(srcdir)/Lib/$$d; \
-@@ -1513,7 +1521,7 @@
+@@ -1514,7 +1522,7 @@
        find build -name 'fficonfig.h' -exec rm -f {} ';' || true
        find build -name '*.py' -exec rm -f {} ';' || true
        find build -name '*.py[co]' -exec rm -f {} ';' || true
index 512a534b9b1d40a946b6829f8588ac0880bb1536..7347be5915f1bb88aceaa47190153e6b772d3059 100644 (file)
@@ -10,7 +10,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3423,7 +3423,7 @@
+@@ -3412,7 +3412,7 @@
  
  AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
  
index 462fed4ce813ac463e379d54af49fe994881f973..63c06b1ebaec6a91577150d852a7da8f80f3de94 100644 (file)
@@ -73,7 +73,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2360,6 +2360,8 @@
+@@ -2349,6 +2349,8 @@
  
  AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
  
index 6b52509b5ac66aff214f2c2cb0d5674c62b63510..f6214d0f9ef5b22a28d4c4d93da28657ccb12433 100644 (file)
@@ -42,16 +42,16 @@ Index: b/Makefile.pre.in
 +              curses pydoc_data $(MACHDEPS)
 +
 +TESTSUBDIRS =         tkinter/test tkinter/test/test_tkinter tkinter/test/test_ttk \
-+              test test/test_asyncio ctypes/test \
++              test test/test_asyncio \
 +              test/test_email test/test_email/data \
 +              test/test_json \
                test/audiodata \
                test/capath test/data \
                test/cjkencodings test/decimaltestdata test/xmltestdata \
-@@ -1148,28 +1170,20 @@
-               test/namespace_pkgs/project3/parent/child \
-                 test/namespace_pkgs/module_and_namespace_package \
-                 test/namespace_pkgs/module_and_namespace_package/a_test \
+@@ -1148,28 +1170,22 @@
+               test/test_importlib/namespace_pkgs/project3/parent/child \
+                 test/test_importlib/namespace_pkgs/module_and_namespace_package \
+                 test/test_importlib/namespace_pkgs/module_and_namespace_package/a_test \
 -              asyncio \
 -              test/test_asyncio \
 -              collections concurrent concurrent/futures encodings \
@@ -61,6 +61,7 @@ Index: b/Makefile.pre.in
 -              sqlite3 sqlite3/test \
 -              logging csv wsgiref urllib \
 -              lib2to3 lib2to3/fixes lib2to3/pgen2 lib2to3/tests \
++              sqlite3/test \
 +              lib2to3/tests \
                lib2to3/tests/data lib2to3/tests/data/fixers \
                lib2to3/tests/data/fixers/myfixes \
@@ -68,7 +69,9 @@ Index: b/Makefile.pre.in
 -              idlelib idlelib/Icons idlelib/idle_test \
 -              distutils distutils/command distutils/tests $(XMLLIBSUBDIRS) \
 -              importlib test/test_importlib test/test_importlib/builtin \
-+              sqlite3/test idlelib/idle_test \
++              ctypes/test \
++              idlelib/idle_test \
++              distutils/tests \
 +              test/test_importlib test/test_importlib/builtin \
                test/test_importlib/extension test/test_importlib/frozen \
                test/test_importlib/import_ test/test_importlib/source \
@@ -77,8 +80,7 @@ Index: b/Makefile.pre.in
 -              unittest unittest/test unittest/test/testmock \
 -              venv venv/scripts venv/scripts/posix \
 -              curses pydoc_data $(MACHDEPS)
-+              unittest/test unittest/test/testmock \
-+              distutils/tests
++              unittest/test unittest/test/testmock
 +
 +ifeq (@TEST_MODULES@,yes)
 +LIBSUBDIRS += $(TESTSUBDIRS)
@@ -91,7 +93,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2667,6 +2667,12 @@
+@@ -2656,6 +2656,12 @@
  fi
  
  
index 331c842d3dddc754a5d1066b1d706ce27bb9f709..ddd54687f89edcc95dda422a0d3347d8215aaf3b 100644 (file)
@@ -34,10 +34,10 @@ Index: b/Makefile.pre.in
 +              curses $(MACHDEPS)
  
  TESTSUBDIRS =         tkinter/test tkinter/test/test_tkinter tkinter/test/test_ttk \
-               test test/test_asyncio ctypes/test \
-@@ -1180,6 +1182,10 @@
-               unittest/test unittest/test/testmock \
-               distutils/tests
+               test test/test_asyncio \
+@@ -1182,6 +1184,10 @@
+               test/test_importlib/import_ test/test_importlib/source \
+               unittest/test unittest/test/testmock
  
 +ifeq (@PYDOC@,yes)
 +LIBSUBDIRS += pydoc_data
@@ -50,7 +50,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2666,6 +2666,11 @@
+@@ -2655,6 +2655,11 @@
        AC_CHECK_FUNCS(pthread_atfork)
  fi
  
@@ -66,7 +66,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -2182,6 +2182,12 @@
+@@ -2203,6 +2203,12 @@
      # turn off warnings when deprecated modules are imported
      import warnings
      warnings.filterwarnings("ignore",category=DeprecationWarning)
@@ -79,7 +79,7 @@ Index: b/setup.py
      setup(# PyPI Metadata (PEP 301)
            name = "Python",
            version = sys.version.split()[0],
-@@ -2206,8 +2212,7 @@
+@@ -2227,8 +2233,7 @@
            # If you change the scripts installed here, you also need to
            # check the PyBuildScripts command above, and change the links
            # created by the bininstall target in Makefile.pre.in
index facf6e178020e4113bff13f77b0c6b34fa1ca919..a23584feb808c61ccd2c0c3be517f10cc0c62e49 100644 (file)
@@ -34,17 +34,17 @@ Index: b/Makefile.pre.in
                ctypes ctypes/macholib \
                idlelib idlelib/Icons \
                distutils distutils/command $(XMLLIBSUBDIRS) \
-@@ -1172,9 +1173,6 @@
-               test/namespace_pkgs/project3/parent/child \
-                 test/namespace_pkgs/module_and_namespace_package \
-                 test/namespace_pkgs/module_and_namespace_package/a_test \
+@@ -1173,9 +1174,6 @@
+                 test/test_importlib/namespace_pkgs/module_and_namespace_package \
+                 test/test_importlib/namespace_pkgs/module_and_namespace_package/a_test \
+               sqlite3/test \
 -              lib2to3/tests \
 -              lib2to3/tests/data lib2to3/tests/data/fixers \
 -              lib2to3/tests/data/fixers/myfixes \
-               sqlite3/test idlelib/idle_test \
-               test/test_importlib test/test_importlib/builtin \
-               test/test_importlib/extension test/test_importlib/frozen \
-@@ -1186,6 +1184,14 @@
+               ctypes/test \
+               idlelib/idle_test \
+               distutils/tests \
+@@ -1188,6 +1186,14 @@
  LIBSUBDIRS += pydoc_data
  endif
  
@@ -59,7 +59,7 @@ Index: b/Makefile.pre.in
  ifeq (@TEST_MODULES@,yes)
  LIBSUBDIRS += $(TESTSUBDIRS)
  endif
-@@ -1281,10 +1287,12 @@
+@@ -1283,10 +1289,12 @@
                -d $(LIBDEST)/site-packages -f $(STDLIB_CACHE_FLAGS) \
                -x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
  endif
@@ -76,7 +76,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -2183,10 +2183,11 @@
+@@ -2204,10 +2204,11 @@
      import warnings
      warnings.filterwarnings("ignore",category=DeprecationWarning)
  
@@ -94,7 +94,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2678,6 +2678,12 @@
+@@ -2667,6 +2667,12 @@
        AS_HELP_STRING([--disable-test-modules], [disable test modules]),
        [ TEST_MODULES="${enableval}" ], [ TEST_MODULES=yes ])
  
index eb8d242053f579600a839dc00ef88f66cd8845c3..e444301dcbcd085981fd75f4131db8abb4eee981 100644 (file)
@@ -12,7 +12,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2666,6 +2666,15 @@
+@@ -2655,6 +2655,15 @@
        AC_CHECK_FUNCS(pthread_atfork)
  fi
  
@@ -40,16 +40,15 @@ Index: b/Makefile.pre.in
                logging csv wsgiref urllib \
                ctypes ctypes/macholib \
                idlelib idlelib/Icons \
-@@ -1173,7 +1172,7 @@
-               test/namespace_pkgs/project3/parent/child \
-                 test/namespace_pkgs/module_and_namespace_package \
-                 test/namespace_pkgs/module_and_namespace_package/a_test \
--              sqlite3/test idlelib/idle_test \
-+              idlelib/idle_test \
-               test/test_importlib test/test_importlib/builtin \
-               test/test_importlib/extension test/test_importlib/frozen \
-               test/test_importlib/import_ test/test_importlib/source \
-@@ -1192,6 +1191,11 @@
+@@ -1173,7 +1172,6 @@
+               test/test_importlib/namespace_pkgs/project3/parent/child \
+                 test/test_importlib/namespace_pkgs/module_and_namespace_package \
+                 test/test_importlib/namespace_pkgs/module_and_namespace_package/a_test \
+-              sqlite3/test \
+               ctypes/test \
+               idlelib/idle_test \
+               distutils/tests \
+@@ -1194,6 +1192,11 @@
        lib2to3/tests/data/fixers/myfixes
  endif
  
index 32e2bee797f99ae58c8b03a1f2c071a4c854f80d..0d15fe1eacebdec923579190476138c5ef943363 100644 (file)
@@ -26,12 +26,12 @@ Index: b/Makefile.pre.in
                curses $(MACHDEPS)
  
 -TESTSUBDIRS =         tkinter/test tkinter/test/test_tkinter tkinter/test/test_ttk \
--              test test/test_asyncio ctypes/test \
-+TESTSUBDIRS =         test test/test_asyncio ctypes/test \
+-              test test/test_asyncio \
++TESTSUBDIRS =         test test/test_asyncio \
                test/test_email test/test_email/data \
                test/test_json \
                test/audiodata \
-@@ -1196,6 +1195,12 @@
+@@ -1197,6 +1196,12 @@
  TESTSUBDIRS += sqlite3/test
  endif
  
@@ -48,7 +48,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2675,6 +2675,15 @@
+@@ -2664,6 +2664,15 @@
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
  fi
  
index 75e2558db98d66dc393d92a4499894989a3232a6..8e6390897fb777c17e8cd96bb28d7d3289ee6c62 100644 (file)
@@ -19,9 +19,9 @@ Index: b/Makefile.pre.in
 -              curses $(MACHDEPS)
 +              $(MACHDEPS)
  
- TESTSUBDIRS =         test test/test_asyncio ctypes/test \
+ TESTSUBDIRS =         test test/test_asyncio \
                test/test_email test/test_email/data \
-@@ -1201,6 +1201,10 @@
+@@ -1202,6 +1202,10 @@
        tkinter/test/test_ttk
  endif
  
@@ -36,7 +36,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2684,6 +2684,15 @@
+@@ -2673,6 +2673,15 @@
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
  fi
  
index 80da9395eec1c16b82629cdd35af7dd92f1cc0b4..ce1eb2a5d9bd1f6752bf92fc3b16087f3e062ea4 100644 (file)
@@ -28,7 +28,7 @@ Index: b/Makefile.pre.in
                importlib \
                turtledemo \
                multiprocessing multiprocessing/dummy \
-@@ -1205,6 +1205,10 @@
+@@ -1206,6 +1206,10 @@
  LIBSUBDIRS += curses
  endif
  
@@ -43,7 +43,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2363,13 +2363,21 @@
+@@ -2352,13 +2352,21 @@
  AC_SUBST(DISABLED_EXTENSIONS)
  
  # Check for use of the system expat library
@@ -74,7 +74,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -1396,7 +1396,7 @@
+@@ -1417,7 +1417,7 @@
          #
          # More information on Expat can be found at www.libexpat.org.
          #
index f9d377d0b5183cf2f9820af3972346cd04c13ae7..0f261fc5706540c755385246610fe1e81bb33133 100644 (file)
@@ -10,7 +10,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2683,6 +2683,12 @@
+@@ -2672,6 +2672,12 @@
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
  fi
  
index 7ec5b19b59f614cece4d10bc0fa5fc2cd47b0b75..de6057c9feb7403f182b54c5abe437ebd84d5789 100644 (file)
@@ -13,7 +13,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2689,6 +2689,12 @@
+@@ -2678,6 +2678,12 @@
                DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _codecs_kr _codecs_jp _codecs_cn _codecs_tw _codecs_hk _codecs_iso2022"
        fi])
  
index 4b671ed9b03fd88757bc1e18586349d43153709b..46e9a6f29473a689a97f3d0d16481d54d8c24ab8 100644 (file)
@@ -10,7 +10,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2695,6 +2695,12 @@
+@@ -2684,6 +2684,12 @@
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
          fi])
  
index f657cbd965822135f0385ae245610d2ff7e32a3a..4d5e70b50c63d0d91f66891afd3269dd177b2e9b 100644 (file)
@@ -33,7 +33,7 @@ Index: b/Makefile.pre.in
                distutils distutils/command \
                importlib \
                turtledemo \
-@@ -1209,6 +1210,10 @@
+@@ -1210,6 +1211,10 @@
  LIBSUBDIRS += $(XMLLIBSUBDIRS)
  endif
  
@@ -48,7 +48,7 @@ Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2737,6 +2737,12 @@
+@@ -2726,6 +2726,12 @@
        AS_HELP_STRING([--disable-lib2to3], [disable lib2to3]),
        [ LIB2TO3="${enableval}" ], [ LIB2TO3=yes ])
  
@@ -65,7 +65,7 @@ Index: b/setup.py
 ===================================================================
 --- a/setup.py
 +++ b/setup.py
-@@ -2183,11 +2183,13 @@
+@@ -2204,11 +2204,13 @@
      import warnings
      warnings.filterwarnings("ignore",category=DeprecationWarning)
  
index 80ad88e8ce0f62cd18b95dcaa0f70aef63e19d40..98fc31b6f84503436dc34facfe6b31750d00d1e4 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 PYTHON3_VERSION_MAJOR = 3.4
-PYTHON3_VERSION = $(PYTHON3_VERSION_MAJOR).0
+PYTHON3_VERSION = $(PYTHON3_VERSION_MAJOR).1
 PYTHON3_SOURCE = Python-$(PYTHON3_VERSION).tar.xz
 PYTHON3_SITE = http://python.org/ftp/python/$(PYTHON3_VERSION)