package/setools: host variant needs host-python-enum34
authorMatt Weber <matthew.weber@rockwellcollins.com>
Fri, 28 Sep 2018 20:04:35 +0000 (15:04 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 9 Oct 2018 13:42:03 +0000 (15:42 +0200)
The enum34 dependency is required for python2.7 for both the host and
target builds.  This patch adds the host dependency to match what is
already in place for the target.

The host build is used by the setools package seinfo tool offline for
host based policy analysis. The analysis is easiest performed offline
as the policy is checked for path/reachability, which is something
that occurs by taking the policy file and using debug libraries to
perform test cases.

Fixes the following runtime error:

$ ./output/host/bin/sesearch
Traceback (most recent call last):
[...]
  File "/home/test/buildroot/output/host/lib/python2.7/site-packages/setools-4.1.1-py2.7-linux-x86_64.egg/setools/policyrep/util.py", line 21, in <module>
    from enum import Enum
ImportError: No module named enum

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/setools/setools.mk

index 1ed7e976d6f0739f003337efdf4792b2e5af5b3f..63ca3651e8787fee7c2a8a007d3fee6cc715a0db 100644 (file)
@@ -18,6 +18,7 @@ SETOOLS_PYLIBVER = python$(PYTHON3_VERSION_MAJOR)
 else
 SETOOLS_PYLIBVER = python$(PYTHON_VERSION_MAJOR)
 SETOOLS_DEPENDENCIES += python-enum34
+HOST_SETOOLS_DEPENDENCIES += host-python-enum34
 endif
 
 define SETOOLS_FIX_SETUP