beecrypt: fix compile for coldfire
authorWaldemar Brodkorb <wbx@openadk.org>
Sat, 18 Jun 2016 11:26:11 +0000 (13:26 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 18 Jun 2016 21:38:29 +0000 (23:38 +0200)
Package uses m68k optimization, which doesn't work with coldfire.
These optimizations are disabled with --enable-debug.

Fixes following autobuild failure:
http://autobuild.buildroot.net/results/bbe57a096de207b78e069591e21ac5a79eab069e/
http://autobuild.buildroot.net/results/ab702e6db382b1975d0cd61feaba9812830e81e8/

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/beecrypt/beecrypt.mk

index e66cec10d68df3c31e9fd3e83fa4a28babd05565..4fcdf439a34a22383567d42e9f66f02906fc0782 100644 (file)
@@ -17,6 +17,11 @@ BEECRYPT_CONF_OPTS = \
        --without-python \
        --disable-openmp
 
+# disable optimized m68k assembly as it doesn't compile for coldfire
+ifeq ($(BR2_m68k_cf),y)
+BEECRYPT_CONF_OPTS += --enable-debug
+endif
+
 ifeq ($(BR2_PACKAGE_BEECRYPT_CPP),y)
 BEECRYPT_DEPENDENCIES += icu
 BEECRYPT_CONF_OPTS += --with-cplusplus