reproducibility: override locale and timezone
authorGilles Chanteperdrix <gilles.chanteperdrix@xenomai.org>
Tue, 14 Jun 2016 15:31:10 +0000 (17:31 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 2 Jul 2016 10:00:24 +0000 (12:00 +0200)
And export BR2_REPRODUCIBLE for post-build / post-image scripts.

[Peter: Extend commit message,
move export together with our other exports,
add comment explaining why we override local/timezone]
Signed-off-by: Gilles Chanteperdrix <gilles.chanteperdrix@xenomai.org>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index 41f02745a851294057cc3b9b9a9f55cd833caa3f..027f21c9039179dc5a50201c24ee764d0629bf21 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -213,6 +213,13 @@ ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
 -include $(BR2_CONFIG)
 endif
 
+# timezone and locale may affect build output
+ifeq ($(BR2_REPRODUCIBLE),y)
+export TZ=UTC
+export LANG=C
+export LC_ALL=C
+endif
+
 # To put more focus on warnings, be less verbose as default
 # Use 'make V=1' to see the full commands
 ifeq ("$(origin V)", "command line")
@@ -410,6 +417,7 @@ endif
 # Scripts in support/ or post-build scripts may need to reference
 # these locations, so export them so it is easier to use
 export BR2_CONFIG
+export BR2_REPRODUCIBLE
 export TARGET_DIR
 export STAGING_DIR
 export HOST_DIR