pciutils: Fix cross compiling
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 6 May 2010 14:24:36 +0000 (11:24 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 6 May 2010 21:07:21 +0000 (23:07 +0200)
Closes #1705

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/pciutils/Config.in
package/pciutils/pciutils.mk

diff --git a/CHANGES b/CHANGES
index 525db270fb467fc241e772eba20581f972d30902..0476fb06064316392bacbcab00a7a8d55cfd70f6 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -2,7 +2,7 @@
 
        Fixes all over the tree.
 
-       Updated/fixed packages: hal, mplayer,
+       Updated/fixed packages: hal, mplayer, pciutils,
        xdriver_xf86-video-openchrome, usb_modeswitch, usbutils
 
        Issues resolved (http://bugs.uclibc.org):
@@ -10,6 +10,7 @@
        #985: Bump usb_modeswitch package to 1.1.0
        #1525: Package hal deletes a whole <target>/etc/rc.d directory
        #1699: Fix usbutils dependencies and bump
+       #1705: Fix pciutils broken cross compiling
 
 2010.05-rc1, Released May 3rd, 2010:
 
index bc026602f58ca3a61c782a6f468d5a991c8e4ae2..07fc49b82cb83d6b7e4ea6254eb1d614a601577f 100644 (file)
@@ -7,4 +7,7 @@ config BR2_PACKAGE_PCIUTILS
          Various utilities dealing with the PCI bus.
          Provides things like setpci and lspci.
 
+         You'll need a copy of pci.ids or pci.ids.gz in your
+         target skeleton to enjoy verbose output.
+
          http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html
index 393162f628c934d234a5d38cf2bb0cbaa763f46a..2b999dfb59e986b8269d7085bf93d515b832b339 100644 (file)
@@ -18,10 +18,12 @@ define PCIUTILS_CONFIGURE_CMDS
        $(SED) 's/uname -s/echo Linux/' \
                -e 's/uname -r/echo $(LINUX_HEADERS_VERSION)/' \
                $(PCIUTILS_DIR)/lib/configure
+       $(SED) 's/^STRIP/#STRIP/' $(PCIUTILS_DIR)/Makefile
 endef
 
 define PCIUTILS_BUILD_CMDS
        $(MAKE) CC="$(TARGET_CC)" \
+               HOST="$(KERNEL_ARCH)-linux" \
                OPT="$(TARGET_CFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
                RANLIB=$(TARGET_RANLIB) \
@@ -33,8 +35,10 @@ define PCIUTILS_BUILD_CMDS
                SHAREDIR=/usr/share/misc
 endef
 
+# Ditch install-lib if SHARED is an option in the future
 define PCIUTILS_INSTALL_TARGET_CMDS
        $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr install
+       $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr install-lib
 endef
 
 $(eval $(call GENTARGETS,package,pciutils))