qt: remove broken iBase driver
authorArnout Vandecappelle <arnout@mind.be>
Tue, 7 Mar 2017 23:50:51 +0000 (00:50 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 9 Mar 2017 21:28:11 +0000 (22:28 +0100)
This option has been marked as broken since 2010. No need for legacy
handling.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
[Thomas: remove dead code in qt.mk, as pointed out by Peter Seiderer.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt/Config.sql.in
package/qt/qt.mk

index 452edd513301332fc01ebde8963a345e2293f7bb..5bd63d27a00a3327b19f1d44d978c80ef5dc3311 100644 (file)
@@ -14,13 +14,6 @@ config BR2_PACKAGE_QT_MYSQL
          Build MySQL driver
          If unsure, say n.
 
-config BR2_PACKAGE_QT_IBASE
-       bool "iBase Driver"
-       depends on BROKEN # libfbclient not in BR
-       help
-         Build iBase driver
-         If unsure, say n.
-
 config BR2_PACKAGE_QT_ODBC
        bool "ODBC Driver"
        select BR2_PACKAGE_UNIXODBC
index 29dcc46b7b793d530dfdbd5ba4dc70140d5d9d19..e82bdfe801f4d195b9bdc10d53105d2365aa97ef 100644 (file)
@@ -359,9 +359,6 @@ endif
 
 # Qt SQL Drivers
 ifeq ($(BR2_PACKAGE_QT_SQL_MODULE),y)
-ifeq ($(BR2_PACKAGE_QT_IBASE),y)
-QT_CONFIGURE_OPTS += -qt-sql-ibase
-endif
 ifeq ($(BR2_PACKAGE_QT_MYSQL),y)
 QT_CONFIGURE_OPTS += -qt-sql-mysql -mysql_config $(STAGING_DIR)/usr/bin/mysql_config
 QT_DEPENDENCIES += mysql