zsh: use the correct target pcre-config
authorBaruch Siach <baruch@tkos.co.il>
Tue, 1 Mar 2016 11:34:55 +0000 (13:34 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 1 Mar 2016 11:48:29 +0000 (12:48 +0100)
zsh configure script mis-detects the location of pcre-config, and may use that
of host-pcre or that of the host instead of the target. Make configure use the
correct pcre-config.

Thanks to Thomas Petazzoni for pointing me at the right direction.

Fixes:
http://autobuild.buildroot.net/results/b12/b12aadf3016dab0941cae780fa9ee7bf9be8fcda/
http://autobuild.buildroot.net/results/8e8/8e8b12dbca4ef8cac2e5f33cd3cdcddd8e849840/
http://autobuild.buildroot.net/results/473/473197ec8e323ea7ae0e29e6363525dc42f9da2c/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/zsh/zsh.mk

index 8659fc40189d753229239309291118c95f18692c..84dbbde56f925c0d2d8d4b55d0b60b0356120d06 100644 (file)
@@ -28,6 +28,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_PCRE),y)
 ZSH_CONF_OPTS += --enable-pcre
+ZSH_CONF_ENV += ac_cv_prog_PCRECONF=$(STAGING_DIR)/usr/bin/pcre-config
 ZSH_DEPENDENCIES += pcre
 else
 ZSH_CONF_OPTS += --disable-pcre