b43-fwcutter: new package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 6 Dec 2012 12:49:59 +0000 (12:49 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 16 Dec 2012 00:11:59 +0000 (01:11 +0100)
b43-fwcutter is an open-source tool (BSD-2c) that extracts the
firmwares from the Broadcom proprietary drivers. Those firmwares can
then be used by the open-source b43 and b43-legacy drivers of the
Linux kernel.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/b43-fwcutter/b43-fwcutter.mk [new file with mode: 0644]

diff --git a/package/b43-fwcutter/b43-fwcutter.mk b/package/b43-fwcutter/b43-fwcutter.mk
new file mode 100644 (file)
index 0000000..b48eb45
--- /dev/null
@@ -0,0 +1,21 @@
+#############################################################
+#
+# b43-fwcutter
+#
+#############################################################
+
+B43_FWCUTTER_VERSION = 015
+B43_FWCUTTER_SITE = http://bues.ch/b43/fwcutter/
+B43_FWCUTTER_SOURCE = b43-fwcutter-$(B43_FWCUTTER_VERSION).tar.bz2
+B43_FWCUTTER_LICENSE = BSD-2c
+B43_FWCUTTER_LICENSE_FILES = COPYING
+
+define HOST_B43_FWCUTTER_BUILD_CMDS
+       $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+define HOST_B43_FWCUTTER_INSTALL_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/b43-fwcutter $(HOST_DIR)/usr/bin/b43-fwcutter
+endef
+
+$(eval $(host-generic-package))