package/binutils: avr32 is gone
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 14 Feb 2015 09:23:10 +0000 (10:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 14 Feb 2015 16:44:12 +0000 (17:44 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/binutils/Config.in.host
package/binutils/binutils.mk

index 0739467cc4dc53cf03e3223435633f5835b14af9..504e9ca22ca70dd146e0c71f64266345b8f66441 100644 (file)
@@ -7,33 +7,28 @@ choice
        help
          Select the version of binutils you wish to use.
 
-       config BR2_BINUTILS_VERSION_2_18_AVR32_1_0_1
-               depends on BR2_avr32
-               bool "binutils 2.18-avr32-1.0.1"
-
        config BR2_BINUTILS_VERSION_2_22
-               depends on !BR2_avr32 && !BR2_aarch64 && !BR2_microblaze && !BR2_powerpc64le
+               depends on !BR2_aarch64 && !BR2_microblaze && !BR2_powerpc64le
                bool "binutils 2.22"
 
        # bfin disabled for newer binutils due to
        # https://sourceware.org/bugzilla/show_bug.cgi?id=17334
        config BR2_BINUTILS_VERSION_2_23_2
-               depends on !BR2_avr32 && !BR2_aarch64 && !BR2_bfin && !BR2_microblaze && !BR2_powerpc64le
+               depends on !BR2_aarch64 && !BR2_bfin && !BR2_microblaze && !BR2_powerpc64le
                bool "binutils 2.23.2"
 
        config BR2_BINUTILS_VERSION_2_24
-               depends on !BR2_avr32 && !BR2_bfin
+               depends on !BR2_bfin
                bool "binutils 2.24"
 
        config BR2_BINUTILS_VERSION_2_25
-               depends on !BR2_avr32 && !BR2_bfin
+               depends on !BR2_bfin
                bool "binutils 2.25"
 
 endchoice
 
 config BR2_BINUTILS_VERSION
        string
-       default "2.18-avr32-1.0.1" if BR2_BINUTILS_VERSION_2_18_AVR32_1_0_1
        default "arc-2014.12"   if BR2_arc
        default "2.22"          if BR2_BINUTILS_VERSION_2_22
        default "2.23.2"        if BR2_BINUTILS_VERSION_2_23_2
index c3b3c18afd6d9d52191730d9b623c72db70f1492..9e992533f3bf525dd3294c43f278728a117a6c13 100644 (file)
@@ -8,17 +8,9 @@
 # If not, we do like other packages
 BINUTILS_VERSION = $(call qstrip,$(BR2_BINUTILS_VERSION))
 ifeq ($(BINUTILS_VERSION),)
-ifeq ($(BR2_avr32),y)
-# avr32 uses a special version
-BINUTILS_VERSION = 2.18-avr32-1.0.1
-else
 BINUTILS_VERSION = 2.22
 endif
-endif
 
-ifeq ($(ARCH),avr32)
-BINUTILS_SITE = ftp://www.at91.com/pub/buildroot
-endif
 ifeq ($(BR2_arc),y)
 BINUTILS_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,binutils-gdb,$(BINUTILS_VERSION))
 BINUTILS_SOURCE = binutils-$(BINUTILS_VERSION).tar.gz