trousers/tpm-tools: enable on ARC
authorEvgeniy Didin <Evgeniy.Didin@synopsys.com>
Thu, 28 Jun 2018 10:58:14 +0000 (13:58 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 28 Jun 2018 20:00:55 +0000 (22:00 +0200)
With the latest ARC toolchain arc-2018.03 builds of "trousers" and
"tpm-tools" packages perform without errors.
Lets enable these packages for ARC.

With the exception, building tpm-tools for ARC770/750 requires to pass
"-mno-compact-casesi" as it was made for trousers before:
see patch f4cd8ceb9cfa "trousers: Pass "-mno-compact-casesi" when
building for ARCv1".
This change is a temporary workaround and the feature is going to be
fixed in the next ARC toolchain release version.

Signed-off-by: Evgeniy Didin <didin@synopsys.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: arc-buildroot@synopsys.com
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/tpm-tools/Config.in
package/tpm-tools/tpm-tools.mk
package/trousers/Config.in

index e11568728142d6aaf28d0f79157603e8a8dba6cb..ca70adc80cd6ef3ca97928562824c82795705983 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_TPM_TOOLS
        bool "tpm-tools"
        depends on BR2_TOOLCHAIN_HAS_THREADS # trousers
        depends on !BR2_STATIC_LIBS # trousers
-       depends on !BR2_arc # trousers
        select BR2_PACKAGE_TROUSERS
        select BR2_PACKAGE_OPENSSL
        help
@@ -12,4 +11,3 @@ config BR2_PACKAGE_TPM_TOOLS
 
 comment "tpm-tools needs a toolchain w/ threads, dynamic library"
        depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
-       depends on !BR2_arc
index b6738251ff37dbab6f1c7138df3f81e785e3c074..623e06fb98b90790fa187741e26b0326e0debec3 100644 (file)
@@ -16,4 +16,8 @@ ifeq ($(BR2_PACKAGE_LIBICONV),y)
 TPM_TOOLS_CONF_ENV += LIBS='-liconv'
 endif
 
+ifeq ($(BR2_arc770d)$(BR2_arc750d),y)
+TPM_TOOLS_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mno-compact-casesi"
+endif
+
 $(eval $(autotools-package))
index 7a1470629a00670c6f4257e8d19fc43df6be2187..998df98398f197888a88a1f92df4257d42ddb08c 100644 (file)
@@ -3,8 +3,6 @@ config BR2_PACKAGE_TROUSERS
        depends on BR2_TOOLCHAIN_HAS_THREADS
        # doesn't build properly in static only configurations
        depends on !BR2_STATIC_LIBS
-       # ARC toolchain issue
-       depends on !BR2_arc
        select BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        help
@@ -18,4 +16,3 @@ config BR2_PACKAGE_TROUSERS
 
 comment "trousers needs a toolchain w/ threads, dynamic library"
        depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
-       depends on !BR2_arc