fs/ext2: hint about setting the filesystem size on error
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 25 Jul 2017 22:05:28 +0000 (00:05 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 25 Jul 2017 22:53:05 +0000 (00:53 +0200)
Since we now request that the user sets the exact size of the ext2/3/4
filesystem, we've had quite a few users wondering what was going on when
they enable too much and the default 60M are no longer enough.

When mkfs.ext2 fails, print a hint that the user should check the size
setting.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
[Arnout: Add *** and redirect to stderr]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
fs/ext2/ext2.mk

index 902e6639ee4fb2ea6ace290f682cc3ef8c8a4d35..5439e2b993b51db682df4e2293b36c794509a46e 100644 (file)
@@ -29,7 +29,11 @@ ROOTFS_EXT2_DEPENDENCIES = host-e2fsprogs
 define ROOTFS_EXT2_CMD
        rm -f $@
        $(HOST_DIR)/sbin/mkfs.ext$(BR2_TARGET_ROOTFS_EXT2_GEN) $(EXT2_OPTS) $@ \
-               "$(EXT2_SIZE)"
+               "$(EXT2_SIZE)" \
+       || { ret=$$?; \
+            echo "*** Maybe you need to increase the filesystem size (BR2_TARGET_ROOTFS_EXT2_SIZE)" 1>&2; \
+            exit $$ret; \
+       }
 endef
 
 rootfs-ext2-symlink: