toolchain-external: adjust musl dynamic linker symlink for mips-sf
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 30 May 2017 09:34:17 +0000 (11:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 30 May 2017 09:39:40 +0000 (11:39 +0200)
The external toolchain code has some logic to calculate the correct name
for the dynamic linker symbolic link that needs to be created when the
musl C library is being used. There was already some handling for the
mipsel+soft-float case, but not for the mips+soft-float case. Due to
this, the symbolic link was incorrectly named, and programs were
referencing an non-existing file.

Reported-by: Florent Jacquet <florent.jacquet@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/pkg-toolchain-external.mk

index 9670350dc048bc98f103230c0d7161fd7501ed4e..856be65669ddd3f1b8170452b876783858f02fb5 100644 (file)
@@ -481,6 +481,8 @@ ifeq ($(BR2_i386),y)
 MUSL_ARCH = i386
 else ifeq ($(BR2_ARM_EABIHF),y)
 MUSL_ARCH = armhf
+else ifeq ($(BR2_mips):$(BR2_SOFT_FLOAT),y:y)
+MUSL_ARCH = mips-sf
 else ifeq ($(BR2_mipsel):$(BR2_SOFT_FLOAT),y:y)
 MUSL_ARCH = mipsel-sf
 else ifeq ($(BR2_sh),y)