package/libv4l: add optional support for alsa-lib
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Jun 2016 20:07:20 +0000 (22:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Jun 2016 20:26:02 +0000 (22:26 +0200)
Add alsa-lib as optional dependency to get a reproducable build.
Without this patch configure logs:

checking for ALSA... no
configure: WARNING: ALSA library not available

After this patch alsa-lib was built before libv4l:
checking for ALSA... yes

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libv4l/libv4l.mk

index d0a0369ee87f7f1d2d36476fca0ef56c542a6d41..e7a57f08bf7d3c8abd8e987b4207312a77c7a88d 100644 (file)
@@ -18,6 +18,10 @@ LIBV4L_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
 LIBV4L_LICENSE = GPLv2+ (utilities), LGPLv2.1+ (libraries)
 LIBV4L_LICENSE_FILES = COPYING COPYING.libv4l lib/libv4l1/libv4l1-kernelcode-license.txt
 
+ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
+LIBV4L_DEPENDENCIES += alsa-lib
+endif
+
 ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
 LIBV4L_DEPENDENCIES += argp-standalone
 LIBV4L_LIBS += -largp