lua-cjson: restore official name
authorFrancois Perrad <fperrad@gmail.com>
Sat, 11 Jan 2014 15:42:08 +0000 (16:42 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 13 Jan 2014 22:17:45 +0000 (23:17 +0100)
(need by LuaRocks)

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/Config.in
package/lua-cjson/Config.in [new file with mode: 0644]
package/lua-cjson/lua-cjson.mk [new file with mode: 0644]
package/luacjson/Config.in [deleted file]
package/luacjson/luacjson.mk [deleted file]

index 052641938792d672e11d0ebf01374787b23ebe4c..754d9de52ae795b496be2f9fc629d30a2be1ee10 100644 (file)
@@ -146,6 +146,13 @@ config BR2_PACKAGE_NETKITTELNET
          been deprecated since 2012.11. 'busybox' provides a telnet
          client and should be used instead.
 
+config BR2_PACKAGE_LUACJSON
+       bool "luacjson has been replaced by lua-cjson"
+       select BR2_PACKAGE_LUA_CJSON
+       select BR2_LEGACY
+       help
+         The option has been renamed BR2_PACKAGE_LUA_CJSON.
+
 ###############################################################################
 comment "Legacy options removed in 2013.11"
 
index 39b0801f87e04ef558d872072b0575f6329467fc..b47d7cba9e342eee5cb5cef9bf2451b024dc36f4 100644 (file)
@@ -368,10 +368,10 @@ source "package/cgilua/Config.in"
 source "package/copas/Config.in"
 source "package/coxpcall/Config.in"
 source "package/lbase64/Config.in"
+source "package/lua-cjson/Config.in"
 source "package/lua-ev/Config.in"
 source "package/lua-msgpack-native/Config.in"
 source "package/luabitop/Config.in"
-source "package/luacjson/Config.in"
 source "package/luacrypto/Config.in"
 source "package/luaexpat/Config.in"
 source "package/luaexpatutils/Config.in"
diff --git a/package/lua-cjson/Config.in b/package/lua-cjson/Config.in
new file mode 100644 (file)
index 0000000..8129fab
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_LUA_CJSON
+       bool "lua-cjson"
+       depends on BR2_PACKAGE_HAS_LUA_INTERPRETER
+       help
+         The Lua CJSON module provides JSON support for Lua. It features:
+         - Fast, standards compliant encoding/parsing routines
+         - Full support for JSON with UTF-8, including decoding surrogate pairs
+         - Optional run-time support for common exceptions to the JSON
+           specification (infinity, NaN, ...)
+         - No dependencies on other libraries
+
+         (C-module)
+
+         http://www.kyne.com.au/~mark/software/lua-cjson.php
diff --git a/package/lua-cjson/lua-cjson.mk b/package/lua-cjson/lua-cjson.mk
new file mode 100644 (file)
index 0000000..92af23f
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# lua-cjson
+#
+################################################################################
+
+LUA_CJSON_VERSION       = 2.1.0
+LUA_CJSON_SITE          = http://www.kyne.com.au/~mark/software/download
+LUA_CJSON_DEPENDENCIES  = luainterpreter
+LUA_CJSON_LICENSE       = MIT
+LUA_CJSON_LICENSE_FILES = LICENSE
+
+define LUA_CJSON_BUILD_CMDS
+       $(MAKE) -C $(@D) \
+               CFLAGS="$(TARGET_CFLAGS)"   \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               CC="$(TARGET_CC)"           \
+               LD="$(TARGET_LD)"           \
+               PREFIX=$(STAGING_DIR)/usr
+endef
+
+define LUA_CJSON_INSTALL_TARGET_CMDS
+       $(MAKE) DESTDIR="$(TARGET_DIR)" PREFIX="/usr" -C $(@D) install
+endef
+
+$(eval $(generic-package))
diff --git a/package/luacjson/Config.in b/package/luacjson/Config.in
deleted file mode 100644 (file)
index d3665c0..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-config BR2_PACKAGE_LUACJSON
-       bool "luacjson"
-       depends on BR2_PACKAGE_HAS_LUA_INTERPRETER
-       help
-         The Lua CJSON module provides JSON support for Lua. It features:
-         - Fast, standards compliant encoding/parsing routines
-         - Full support for JSON with UTF-8, including decoding surrogate pairs
-         - Optional run-time support for common exceptions to the JSON
-           specification (infinity, NaN, ...)
-         - No dependencies on other libraries
-
-         (C-module)
-
-         http://www.kyne.com.au/~mark/software/lua-cjson.php
diff --git a/package/luacjson/luacjson.mk b/package/luacjson/luacjson.mk
deleted file mode 100644 (file)
index 86be875..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-################################################################################
-#
-# luacjson
-#
-################################################################################
-
-LUACJSON_VERSION       = 2.1.0
-LUACJSON_SOURCE        = lua-cjson-$(LUACJSON_VERSION).tar.gz
-LUACJSON_SITE          = http://www.kyne.com.au/~mark/software/download
-LUACJSON_DEPENDENCIES  = luainterpreter
-LUACJSON_LICENSE       = MIT
-LUACJSON_LICENSE_FILES = LICENSE
-
-define LUACJSON_BUILD_CMDS
-       $(MAKE) -C $(@D) \
-               CFLAGS="$(TARGET_CFLAGS)"   \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
-               CC="$(TARGET_CC)"           \
-               LD="$(TARGET_LD)"           \
-               PREFIX=$(STAGING_DIR)/usr
-endef
-
-define LUACJSON_INSTALL_TARGET_CMDS
-       $(MAKE) DESTDIR="$(TARGET_DIR)" PREFIX="/usr" -C $(@D) install
-endef
-
-$(eval $(generic-package))