- disable sysroot support for anything but the current, stable release series
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sun, 24 Jun 2007 11:30:05 +0000 (11:30 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sun, 24 Jun 2007 11:30:05 +0000 (11:30 -0000)
toolchain/gcc/Config.in
toolchain/gcc/gcc-uclibc-3.x.mk
toolchain/gcc/gcc-uclibc-4.x.mk

index 3dc5352ca3fd48ebfca35e9243a5cc014ecfda90..fa60e38db09ef43fa6f2027307df35990fbc6a9f 100644 (file)
@@ -52,7 +52,7 @@ choice
                bool "gcc 4.0.3"
 
        config BR2_GCC_VERSION_4_0_4
-               depends !BR2_nios2
+               depends !BR2_nios2 && BR2_DEPRECATED
                bool "gcc 4.0.4"
 
        config BR2_GCC_VERSION_4_1_0
@@ -84,7 +84,7 @@ config BR2_GCC_IS_SNAP
 
 config BR2_GCC_SNAP_DATE
        string "GCC snapshot date"
-       default "20070601"
+       default "20070622"
        depends BR2_GCC_IS_SNAP
        help
          Enter snapshot date to use for gcc.  Format is:
@@ -113,7 +113,7 @@ config BR2_GCC_VERSION
 config BR2_TOOLCHAIN_SYSROOT
 #      bool "Enable toolchain with --sysroot support"
        bool
-       depends on !BR2_GCC_VERSION_3_3_5 && !BR2_GCC_VERSION_3_3_6 && !BR2_GCC_VERSION_3_4_2 && !BR2_GCC_VERSION_3_4_3 && !BR2_GCC_VERSION_3_4_4 && !BR2_GCC_VERSION_3_4_5 && !BR2_GCC_VERSION_3_4_6
+       depends on !BR2_GCC_VERSION_3_3_5 && !BR2_GCC_VERSION_3_3_6 && !BR2_GCC_VERSION_3_4_2 && !BR2_GCC_VERSION_3_4_3 && !BR2_GCC_VERSION_3_4_4 && !BR2_GCC_VERSION_3_4_5 && !BR2_GCC_VERSION_3_4_6 &&!BR2_GCC_VERSION_4_0_0 && !BR2_GCC_VERSION_4_0_1 && !BR2_GCC_VERSION_4_0_2 && !BR2_GCC_VERSION_4_0_3 && !BR2_GCC_VERSION_4_0_4 && !BR2_GCC_VERSION_4_1_0 && !BR2_GCC_VERSION_4_1_1 && !BR2_GCC_VERSION_4_1_2
        default y
        help
          Enables --sysroot=dir for binutils and gcc.
@@ -122,6 +122,9 @@ config BR2_TOOLCHAIN_SYSROOT
          /usr/include and libraries in /usr/lib, it will instead search
          dir/usr/include and dir/usr/lib.
 
+         This does not work with gcc < 4.2.0 (4.1.2 gets
+         ORIGINAL_AS_FOR_TARGET wrong)
+
 config BR2_GCC_USE_SJLJ_EXCEPTIONS
        bool "Enable setjmp/longjmp exceptions?"
        default n
index 8d8e6f21ed35f0b4c03b2bc4cf8a6f35a906e4c1..2e81c96ca5077b3ac8b3eabcb3fe06b7db7638db 100644 (file)
@@ -19,8 +19,8 @@
 
 ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
 
-# only for gcc-3.x
-ifeq ($(findstring y,$(BR2_GCC_VERSION_3_3_5)$(BR2_GCC_VERSION_3_3_6)$(BR2_GCC_VERSION_3_4_2)$(BR2_GCC_VERSION_3_4_3)$(BR2_GCC_VERSION_3_4_4)$(BR2_GCC_VERSION_3_4_5)$(BR2_GCC_VERSION_3_4_6)),y)
+# without sysroot support. Sysroot toolchain is gcc-uclibc-4.x.mk
+ifneq ($(BR2_TOOLCHAIN_SYSROOT),y)
 
 ifeq ($(GCC_SNAP_DATE),)
 GCC_OFFICIAL_VER:=$(GCC_VERSION)
index 2d69bdd9481fd85e195c4864c3017c70237efb77..89f7a45e9a7c76041f9e55adf3eb73b2b9618452 100644 (file)
@@ -17,8 +17,9 @@
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
 
-# gcc-4.x only
-ifeq ($(findstring y,$(BR2_GCC_VERSION_3_3_5)$(BR2_GCC_VERSION_3_3_6)$(BR2_GCC_VERSION_3_4_2)$(BR2_GCC_VERSION_3_4_3)$(BR2_GCC_VERSION_3_4_4)$(BR2_GCC_VERSION_3_4_5)$(BR2_GCC_VERSION_3_4_6)),)
+# sysroot support works with gcc >= 4.2.0 only
+ifeq ($(BR2_TOOLCHAIN_SYSROOT),y)
+
 ifeq ($(GCC_SNAP_DATE),)
 GCC_OFFICIAL_VER:=$(GCC_VERSION)
 GCC_SITE:=http://ftp.gnu.org/gnu/gcc/gcc-$(GCC_VERSION)