webkit: fix target install
authorSimon Dawson <spdawson@gmail.com>
Mon, 21 Oct 2013 13:25:29 +0000 (14:25 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 22 Oct 2013 14:29:07 +0000 (16:29 +0200)
Commit 33a9d34ff375ec0c0389c9af6bc499a8dd7ccbc9 fixed the staging
install for webkit, which was hanging due to deadlock during parallel
make install.

This problem also afflicts the target install, which is fixed by this patch.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/webkit/webkit.mk

index eb1547bba6e51bd19b8c7f38e96d6b29ff49e0d2..21b535ffe14bd61c94929560d83a447a0f252e3c 100644 (file)
@@ -17,6 +17,7 @@ WEBKIT_AUTORECONF_OPT = -I $(@D)/Source/autotools
 
 # parallel make install deadlocks with make 3.81
 WEBKIT_INSTALL_STAGING_OPT = -j1 DESTDIR=$(STAGING_DIR) install
+WEBKIT_INSTALL_TARGET_OPT = -j1 DESTDIR=$(TARGET_DIR) install
 
 # Does not build and it's disabled by default
 # in newer releases