axfs: add new filesystem type
authorAriel D'Alessandro <ariel@vanguardiasur.com.ar>
Wed, 14 Oct 2015 19:51:26 +0000 (16:51 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 14 Oct 2015 21:47:30 +0000 (23:47 +0200)
The Advanced XIP File System is a Linux kernel filesystem driver that
enables files to be executed directly from flash or ROM memory rather
than being copied into RAM. It has the ability to store individual
*pages* in a file uncompressed/XIP or compressed/Demand Paged.

This commit only adds support for 'XIP all' mode, so all the files that
have the execute attribute set will be XIP'ed.

At the moment, the FS is not supported in Linux mainline (v4.3-rc5), so
the kernel has to be built with the axfs patches to be able to read it.
Patches can be found here: https://github.com/jaredeh/axfs

[Thomas: rewrap Config.in help text.]

Signed-off-by: Ariel D'Alessandro <ariel@vanguardiasur.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
fs/Config.in
fs/axfs/Config.in [new file with mode: 0644]
fs/axfs/axfs.mk [new file with mode: 0644]

index 585311342788d5309880cdedd94a9e80b66248c3..51ccf28169efebe225550c80f80524e6e639c47a 100644 (file)
@@ -1,5 +1,6 @@
 menu "Filesystem images"
 
+source "fs/axfs/Config.in"
 source "fs/cloop/Config.in"
 source "fs/cpio/Config.in"
 source "fs/cramfs/Config.in"
diff --git a/fs/axfs/Config.in b/fs/axfs/Config.in
new file mode 100644 (file)
index 0000000..eaaf7db
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_TARGET_ROOTFS_AXFS
+       bool "axfs root filesystem"
+       help
+         The Advanced XIP File System is a Linux kernel filesystem
+         driver that enables files to be executed directly from flash
+         or ROM memory rather than being copied into RAM. It has the
+         ability to store individual *pages* in a file
+         uncompressed/XIP or compressed/Demand Paged.
+
+         So far, the only supported mode is 'XIP all', so all the
+         files that have the execute attribute set will be XIP'ed.
+
+         At the moment, the FS is not supported in Linux mainline
+         (v4.3-rc5), so the kernel has to be built with the axfs
+         patches to be able to read it. Patches can be found at:
+
+           https://github.com/jaredeh/axfs
diff --git a/fs/axfs/axfs.mk b/fs/axfs/axfs.mk
new file mode 100644 (file)
index 0000000..05d6e5d
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# Build the axfs root filesystem image
+#
+################################################################################
+
+ROOTFS_AXFS_DEPENDENCIES = host-axfsutils
+
+define ROOTFS_AXFS_CMD
+       $(HOST_DIR)/usr/bin/mkfs.axfs -s -a $(TARGET_DIR) $@
+endef
+
+$(eval $(call ROOTFS_TARGET,axfs))