package/squid: add optional systemd dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 23 Jul 2020 21:56:22 +0000 (23:56 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 25 Jul 2020 06:03:12 +0000 (08:03 +0200)
systemd is an optional dependency (enabled by default) since version
4.11 and
https://github.com/squid-cache/squid/commit/6fa8c66435d55a2e713db0222cdca3a9dccf5bbe

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/squid/squid.mk

index d281eee3ed5d18280663286177ac7d5ba805445e..ef2f84085c86764382f99fe455a55599d1759b55 100644 (file)
@@ -62,6 +62,13 @@ else
 SQUID_CONF_OPTS += --without-gnutls
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+SQUID_CONF_OPTS += --with-systemd
+SQUID_DEPENDENCIES += systemd
+else
+SQUID_CONF_OPTS += --without-systemd
+endif
+
 define SQUID_CLEANUP_TARGET
        rm -f $(addprefix $(TARGET_DIR)/usr/bin/, \
                RunCache RunAccel)