readline: s/BR2_READLINE/BR2_PACKAGE_READLINE/
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 30 Jan 2009 09:54:59 +0000 (09:54 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 30 Jan 2009 09:54:59 +0000 (09:54 -0000)
Package configs should start with BR2_PACKAGE_.

25 files changed:
package/database/mysql_client/Config.in
package/database/sqlite/Config.in
package/ipsec-tools/Config.in
package/lua/Config.in
package/php/Config.ext
package/readline/Config.in
package/readline/readline.mk
scripts/test/Config.in.test.buildall
target/device/ARMLTD/integrator926/integrator926_defconfig
target/device/ARMLTD/integrator926_huge/integrator926_huge_defconfig
target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
target/device/Atmel/at91sam9263ek/at91sam9263ek_defconfig
target/device/Atmel/at91sam9g20dfc/at91sam9g20dfc_defconfig
target/device/Atmel/atngw100-base/atngw100-base_defconfig
target/device/Atmel/atngw100-expanded/atngw100-expanded_defconfig
target/device/Atmel/atngw100/atngw100_defconfig
target/device/Atmel/atstk1005/atstk1005_defconfig
target/device/Atmel/atstk100x/atstk100x_defconfig
target/device/KwikByte/kb9202/kb9202_defconfig
target/device/valka/v100sc2_defconfig
target/device/x86/i686/i386_defconfig
target/device/x86/i686/i686_defconfig

index 01cf71725f84c9e8423980a5196704f37866cddf..92b349af95dc10c0161bc80a41fb88f7527516bc 100644 (file)
@@ -2,7 +2,7 @@ config BR2_PACKAGE_MYSQL_CLIENT
        bool "MySQL 5.1 client"
        depends on BR2_INSTALL_LIBSTDCPP
        select BR2_PACKAGE_NCURSES
-       select BR2_READLINE
+       select BR2_PACKAGE_READLINE
        help
          MySQL client
 
index 344af8def6928193f1c13473cbcced3b0d32432b..c445c1e301c58975c8d0def8222ee5b6f388b42c 100644 (file)
@@ -1,7 +1,7 @@
 config BR2_PACKAGE_SQLITE
        bool "sqlite"
        select BR2_PACKAGE_NCURSES
-       select BR2_READLINE
+       select BR2_PACKAGE_READLINE
        help
          SQLite is a small C library that implements a self-contained,
          embeddable, zero-configuration SQL database engine.
index f4e227f557b148424f562521412402bde06e7267..50777ab39b566f89f3b4201658beb2869337e637 100644 (file)
@@ -51,7 +51,7 @@ config BR2_PACKAGE_IPSEC_TOOLS_IPV6
 
 config BR2_PACKAGE_IPSEC_TOOLS_READLINE
        depends on BR2_PACKAGE_IPSEC_TOOLS
-       select BR2_READLINE
+       select BR2_PACKAGE_READLINE
        bool "Enable readline input support if available."
 
 config BR2_PACKAGE_IPSEC_TOOLS_LIBS
index 89de1a82170d7ace66b782cf2602695876030b92..95108cdc3a92bdcefc34b16ca4489252a7a481de 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_LUA
        bool "lua"
-       select BR2_READLINE
+       select BR2_PACKAGE_READLINE
        select BR2_PACKAGE_NCURSES
        help
          Lua is a powerful, fast, light-weight, embeddable scripting language.
index f25c9372945e1ed23185c1f66d9273af8eb3ba18..7f583fcf85d52ab4d866de1594fb2da8092192bf 100644 (file)
@@ -86,7 +86,7 @@ config BR2_PACKAGE_PHP_EXT_JSON
 
 config BR2_PACKAGE_PHP_EXT_READLINE
        bool "readline"
-       depends on BR2_PACKAGE_PHP && (BR2_PACKAGE_PHP_CLI || BR2_PACKAGE_PHP_CGI) && BR2_READLINE
+       depends on BR2_PACKAGE_PHP && (BR2_PACKAGE_PHP_CLI || BR2_PACKAGE_PHP_CGI) && BR2_PACKAGE_READLINE
        help
          readline support
 
index 9ab61abc1103ee132dc5b85975d0df209e2547d9..4319b8b54bada55bc78989592c3a5d138d80f667 100644 (file)
@@ -1,5 +1,5 @@
 #
-config BR2_READLINE
+config BR2_PACKAGE_READLINE
        bool "readline"
        help
            Enable GNU readline support?
index 44b1a01b03d0ce5ce43b35a2ff51fce8fa5645e1..716d86fd03acda6ed43b7d714267523ddb2535b5 100644 (file)
@@ -86,6 +86,6 @@ readline-clean:
 readline-dirclean:
        rm -rf $(READLINE_DIR)
 
-ifeq ($(BR2_READLINE),y)
+ifeq ($(BR2_PACKAGE_READLINE),y)
 TARGETS+=readline
 endif
index 6a5e21124a7bc08222e242109c0b5bc45582a167..163387dd9b1f6dd4fa261ca48ecd4a88347bebde 100644 (file)
@@ -45,7 +45,7 @@ config BR2_TARGET_TEST_PACKAGES
        select BR2_PACKAGE_MPATROL
        select BR2_PACKAGE_OPROFILE
        select BR2_PACKAGE_PKGCONFIG
-       select BR2_READLINE
+       select BR2_PACKAGE_READLINE
                select BR2_PACKAGE_READLINE_TARGET
                select BR2_PACKAGE_READLINE_HEADERS
 
index 06694737967bcd1fe91dae24771da3cc34351067..872aab100c0f0e93632b5570ca90185a3a45d788 100644 (file)
@@ -306,7 +306,7 @@ BR2_HOST_FAKEROOT=y
 # oprofile requires a toolchain with C++ support enabled
 #
 # BR2_PACKAGE_PKGCONFIG is not set
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
 # BR2_PACKAGE_PCRE is not set
 
 #
index 847f177969fae7e2129e19c2c05e8c716335c2fa..652eaf3c446469347b301e332447ec39f2745f11 100644 (file)
@@ -311,7 +311,7 @@ BR2_PACKAGE_M4=y
 # BR2_PACKAGE_MPATROL is not set
 # BR2_PACKAGE_OPROFILE is not set
 BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
 BR2_PACKAGE_READLINE_TARGET=y
 # BR2_PACKAGE_READLINE_HEADERS is not set
 # BR2_PACKAGE_PCRE is not set
index 3b1d963b1b1143f5ae99c075f224aa47895dd4dc..188f7348327683c898b61c5540bd500b8e7ad130 100644 (file)
@@ -373,7 +373,7 @@ BR2_PACKAGE_LIBINTL=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
 BR2_PACKAGE_READLINE_TARGET=y
 # BR2_PACKAGE_READLINE_HEADERS is not set
 # BR2_PACKAGE_PCRE is not set
index f99042444cbae8550885fbc3e48f1d26b4a10c3c..5de12047097d258900e31f16b92fc42c067cfb5a 100644 (file)
@@ -387,7 +387,7 @@ BR2_PACKAGE_LIBINTL=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
 BR2_PACKAGE_READLINE_TARGET=y
 # BR2_PACKAGE_READLINE_HEADERS is not set
 # BR2_PACKAGE_PCRE is not set
index 365a2aa6845a2c5353d42b233a517a289968ecc5..7b3a250d2bd505d331df70106a4f72fd76dadf1f 100644 (file)
@@ -284,7 +284,7 @@ BR2_PACKAGE_LIBINTL=y
 BR2_PACKAGE_LIBTOOL=y
 BR2_PACKAGE_M4=y
 BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
 BR2_PACKAGE_READLINE_TARGET=y
 # BR2_PACKAGE_XERCES is not set
 
index b1dd96ffdb31539fc46f74d15d6155e740e16330..10bda4745d9b6d25606b9a72056760beec0ca4bd 100644 (file)
@@ -381,7 +381,7 @@ BR2_PACKAGE_LIBINTL=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
 BR2_PACKAGE_READLINE_TARGET=y
 # BR2_PACKAGE_READLINE_HEADERS is not set
 # BR2_PACKAGE_PCRE is not set
index fb701895688679c6ef6feeb0aa2a21f97ce832be..006fc6d4e6bd5fae7a0d2fed0ae6f1645eeb5339 100644 (file)
@@ -378,7 +378,7 @@ BR2_PACKAGE_LIBINTL=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
 BR2_PACKAGE_READLINE_TARGET=y
 # BR2_PACKAGE_READLINE_HEADERS is not set
 # BR2_PACKAGE_PCRE is not set
index 11d5344e18c00fe6cb62975cbea6aa35d37bc99f..9034bd73d88b8b65e7574828a0552abad0509584 100644 (file)
@@ -378,7 +378,7 @@ BR2_PACKAGE_LIBINTL=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
 BR2_PACKAGE_READLINE_TARGET=y
 # BR2_PACKAGE_READLINE_HEADERS is not set
 # BR2_PACKAGE_PCRE is not set
index aacac6f8899c01fa562c6ced26ae085506fa7a87..cb231ca7bfbf1c73a592a29d3bbb8dde7ba845b7 100644 (file)
@@ -326,7 +326,7 @@ BR2_HOST_FAKEROOT=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 BR2_PACKAGE_PKGCONFIG=y
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
 # BR2_PACKAGE_PCRE is not set
 
 #
index 4852ba93622d00926b85ea546879791a60291eb5..0f30ad42a9a812168db8384fe2d422de298841f6 100644 (file)
@@ -336,7 +336,7 @@ BR2_PACKAGE_LIBINTL=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 BR2_PACKAGE_PKGCONFIG=y
-BR2_READLINE=y
+BR2_PACKAGE_READLINE=y
 # BR2_PACKAGE_READLINE_TARGET is not set
 # BR2_PACKAGE_PCRE is not set
 
index c4a2fc817b166f4c08b9e7937ade7b38fba4a71b..6c4ada2d3158218280072239a75480812300451b 100644 (file)
@@ -326,7 +326,7 @@ BR2_PACKAGE_LIBINTL=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 BR2_PACKAGE_PKGCONFIG=y
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
 # BR2_PACKAGE_PCRE is not set
 
 #
index f788fa048712b25e002f951465c3dd5f3f7a14a0..761caa43cfa69a3cff091b967c9cd93df7bbb9de 100644 (file)
@@ -326,7 +326,7 @@ BR2_PACKAGE_LIBINTL=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 BR2_PACKAGE_PKGCONFIG=y
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
 # BR2_PACKAGE_PCRE is not set
 
 #
index db4155ddb8b6ea7ef73601dec582350467f9370d..5942fd2e37cf192027dc8d11637b6376e6ffea25 100644 (file)
@@ -336,7 +336,7 @@ BR2_PACKAGE_LIBINTL=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 BR2_PACKAGE_PKGCONFIG=y
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
 # BR2_PACKAGE_PCRE is not set
 
 #
index 6ec31d30ce59b0b49c1bdf5b2c4ed1f89f8e5d27..d90f41542457c7d60ba42e251980c5616da1136a 100644 (file)
@@ -302,7 +302,7 @@ BR2_HOST_FAKEROOT=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 # BR2_PACKAGE_PKGCONFIG is not set
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
 # BR2_PACKAGE_PCRE is not set
 
 #
index f5134ae04c37cecdd43951abad580d6df4319183..c087609dbd33e3c6eeb36f66f60d3d92e9cc58e4 100644 (file)
@@ -299,7 +299,7 @@ BR2_PACKAGE_LIBINTL=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 BR2_PACKAGE_PKGCONFIG=y
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
 BR2_PACKAGE_PCRE=y
 # BR2_PACKAGE_TMC is not set
 
index 4bee5c6a52719b483acd6fba85179f62205892ab..319094cfb8eeff75d9136f70b24115a3f6a77f2e 100644 (file)
@@ -312,7 +312,7 @@ BR2_HOST_FAKEROOT=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 # BR2_PACKAGE_PKGCONFIG is not set
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
 # BR2_PACKAGE_VALGRIND is not set
 # BR2_PACKAGE_PCRE is not set
 
index bce241125e3f800b17bd88881884d1da5626df3b..ad914cbe6d601ff8f6f37c3172b76cd21407623e 100644 (file)
@@ -312,7 +312,7 @@ BR2_HOST_FAKEROOT=y
 # BR2_PACKAGE_M4 is not set
 # BR2_PACKAGE_OPROFILE is not set
 # BR2_PACKAGE_PKGCONFIG is not set
-# BR2_READLINE is not set
+# BR2_PACKAGE_READLINE is not set
 # BR2_PACKAGE_VALGRIND is not set
 # BR2_PACKAGE_PCRE is not set