package/libuio: fix build with external intl library
authorRomain Naour <romain.naour@gmail.com>
Sat, 2 Jul 2016 09:00:06 +0000 (11:00 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 2 Jul 2016 11:26:33 +0000 (13:26 +0200)
When intl library is not provided by the libc, libuio forgets to link
with -lintl.

Fixes:
http://autobuild.buildroot.net/results/8f7/8f715b4e9b826dac13f3d49da25576e6e1d79449

[Peter: simplify using LIBUIO_LIBS as suggested by Yann]
Signed-off-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libuio/libuio.mk

index e019fe962d3dcaa7b6179774d24c201a3ffde396..ed842a9870e6b2e93efd33bad71a92e800ee2a7b 100644 (file)
@@ -21,7 +21,16 @@ LIBUIO_CONF_ENV += MAKEINFO=true
 
 ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
 LIBUIO_DEPENDENCIES += argp-standalone
-LIBUIO_CONF_ENV += LIBS="-largp"
+LIBUIO_LIBS += -largp
 endif
 
+# libuio pulls in libintl if needed, so ensure we also
+# link against it, otherwise static linking fails
+ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
+LIBUIO_DEPENDENCIES += gettext
+LIBUIO_LIBS += -lintl
+endif
+
+LIBUIO_CONF_ENV += LIBS="$(LIBUIO_LIBS)"
+
 $(eval $(autotools-package))