package/pkg-kconfig: fix error string
authorGiulio Benetti <giulio.benetti@benettiengineering.com>
Mon, 29 Mar 2021 22:41:54 +0000 (00:41 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 30 Mar 2021 19:55:51 +0000 (21:55 +0200)
Current error string speaks only about "fragment" but here we also deal
with Kconfig files, so let's add "file or fragment" instead of "fragment".

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-kconfig.mk

index 2aecf2e203bf23981e0744f313b09ee25aa08d9a..dd727b7200ce3111d590062f57c6d1cca9214cc9 100644 (file)
@@ -117,7 +117,7 @@ $(2)_KCONFIG_STAMP_DOTCONFIG = .stamp_dotconfig
 $$($(2)_KCONFIG_FILE) $$($(2)_KCONFIG_FRAGMENT_FILES): | $(1)-patch
        for f in $$($(2)_KCONFIG_FILE) $$($(2)_KCONFIG_FRAGMENT_FILES); do \
                if [ ! -f "$$$${f}" ]; then \
-                       printf "Kconfig fragment '%s' for '%s' does not exist\n" "$$$${f}" "$(1)"; \
+                       printf "Kconfig file or fragment '%s' for '%s' does not exist\n" "$$$${f}" "$(1)"; \
                        exit 1; \
                fi; \
        done