mpd: new features
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 10 Feb 2011 17:58:14 +0000 (14:58 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 10 Feb 2011 21:47:19 +0000 (22:47 +0100)
* Add libcue support (.cue file parsing)
* Add lame support (mp3 encoding)
* Fix slight typo in Config.in wrt LIBCUEFILE

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/mpd/Config.in
package/multimedia/mpd/mpd.mk

index 3906a5f93ce155cee7cf8d608bad9bcf7e484c9c..e418d32c19e5eb4a9f5678491972d349fd41221f 100644 (file)
@@ -53,6 +53,18 @@ config BR2_PACKAGE_MPD_FLAC
          Enable flac input/streaming support.
          Select this if you want to play back FLAC files.
 
+config BR2_PACKAGE_MPD_LAME
+       bool "lame"
+       select BR2_PACKAGE_LAME
+       help
+         Enable lame (mp3) encoding support.
+
+config BR2_PACKAGE_MPD_LIBCUE
+       bool "libcue"
+       select BR2_PACKAGE_LIBCUE
+       help
+         Enable cue file support.
+
 config BR2_PACKAGE_MPD_LIBSAMPLERATE
        bool "libsamplerate"
        select BR2_PACKAGE_LIBSAMPLERATE
@@ -86,7 +98,7 @@ config BR2_PACKAGE_MPD_MPG123
 
 config BR2_PACKAGE_MPD_MUSEPACK
        bool "musepack"
-       select BR2_PACKAGE_LIBCUE
+       select BR2_PACKAGE_LIBCUEFILE
        select BR2_PACKAGE_LIBREPLAYGAIN
        select BR2_PACKAGE_MUSEPACK
        help
index 61b107b389d371ae76863f90afd3985b91608f81..728feaa06f4c918443e584ac761ce57653326bef 100644 (file)
@@ -44,6 +44,18 @@ else
 MPD_CONF_OPT += --disable-curl
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_LAME),y)
+MPD_DEPENDENCIES += lame
+else
+MPD_CONF_OPT += --disable-lame-encoder
+endif
+
+ifeq ($(BR2_PACKAGE_MPD_LIBCUE),y)
+MPD_DEPENDENCIES += libcue
+else
+MPD_CONF_OPT += --disable-cue
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_LIBSAMPLERATE),y)
 MPD_DEPENDENCIES += libsamplerate
 else