package/efl/libevas: add optional dependency on libfribidi
authorFabio Porcedda <fabio.porcedda@gmail.com>
Fri, 27 Feb 2015 09:19:23 +0000 (10:19 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 1 Mar 2015 21:02:15 +0000 (22:02 +0100)
Fix the following message when libfribidi is enabled but not already
built:
Package fribidi was not found in the pkg-config search path.
Perhaps you should add the directory containing `fribidi.pc'
No package 'fribidi' found

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/efl/libevas/libevas.mk

index 40a01e76a2b0d4849e7720a177e381f6e4d92b9a..10c3bc3af26dcdc9da9655a39f690a5f76451e07 100644 (file)
@@ -225,6 +225,13 @@ else
 LIBEVAS_CONF_OPTS += --disable-fontconfig
 endif
 
+ifeq ($(BR2_PACKAGE_LIBFRIBIDI),y)
+LIBEVAS_CONF_OPTS += --enable-fribidi
+LIBEVAS_DEPENDENCIES += libfribidi
+else
+LIBEVAS_CONF_OPTS += --disable-fribidi
+endif
+
 # libevas installs the source code of examples on the target, which
 # are generally not useful.
 define LIBEVAS_REMOVE_EXAMPLES