htop: enable unicode if possible
authorJérôme Pouiller <jezz@sysmic.org>
Mon, 14 Nov 2016 11:04:48 +0000 (12:04 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Nov 2016 12:02:04 +0000 (13:02 +0100)
Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
[Thomas:
 - use positive logic
 - use += instead of = in conditions.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/htop/htop.mk

index 7409a78e287af8c06bcaad4c31884d97d6f7e710..adc509014620d6a1424235bd5edfb8a7dde61fb1 100644 (file)
@@ -7,10 +7,15 @@
 HTOP_VERSION = 2.0.2
 HTOP_SITE = http://hisham.hm/htop/releases/$(HTOP_VERSION)
 HTOP_DEPENDENCIES = ncurses
-HTOP_CONF_OPTS = --disable-unicode
 # Prevent htop build system from searching the host paths
 HTOP_CONF_ENV = HTOP_NCURSES_CONFIG_SCRIPT=$(STAGING_DIR)/usr/bin/ncurses5-config
 HTOP_LICENSE = GPLv2
 HTOP_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
+HTOP_CONF_OPTS += --enable-unicode
+else
+HTOP_CONF_OPTS += --disable-unicode
+endif
+
 $(eval $(autotools-package))