package/freescale-imx/imx-gpu-viv: use make loops instead of shell loops
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 5 Aug 2021 21:27:35 +0000 (23:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 20 Aug 2021 21:37:42 +0000 (23:37 +0200)
We generally prefer using make loops instead of shell loops. They
bring automatic error handling, as they abort the loop when there is
an error, without the need for "|| exit 1".

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Reviewed-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/freescale-imx/imx-gpu-viv/imx-gpu-viv.mk

index df39d3ddc24149770a775d6030dcbe739336587b..fec19523a3ab3f8103f632df841162fc0a15bcc8 100644 (file)
@@ -52,9 +52,9 @@ define IMX_GPU_VIV_FIXUP_PKGCONFIG
 endef
 else ifeq ($(IMX_GPU_VIV_LIB_TARGET),x11)
 define IMX_GPU_VIV_FIXUP_PKGCONFIG
-       for lib in egl gbm glesv1_cm glesv2 vg; do \
-               ln -sf $${lib}_x11.pc $(@D)/gpu-core/usr/lib/pkgconfig/$${lib}.pc || exit 1; \
-       done
+       $(foreach lib,egl gbm glesv1_cm glesv2 vg, \
+               ln -sf $(lib)_x11.pc $(@D)/gpu-core/usr/lib/pkgconfig/$(lib).pc
+       )
 endef
 endif
 
@@ -63,9 +63,9 @@ endif
 # Make sure these commands are idempotent.
 define IMX_GPU_VIV_BUILD_CMDS
        cp -dpfr $(@D)/gpu-core/usr/lib/$(IMX_GPU_VIV_LIB_TARGET)/* $(@D)/gpu-core/usr/lib/
-       for backend in fb x11 wayland; do \
-               $(RM) -r $(@D)/gpu-core/usr/lib/$$backend ; \
-       done
+       $(foreach backend,fb x11 wayland, \
+               $(RM) -r $(@D)/gpu-core/usr/lib/$(backend)
+       )
        $(IMX_GPU_VIV_FIXUP_PKGCONFIG)
 endef