Makefile: distclean: remove correct dirs
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 17 Apr 2009 13:53:07 +0000 (13:53 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 17 Apr 2009 13:53:07 +0000 (13:53 -0000)
Remove toolchain build dir, and don't try to remove the non-existing include
dir. Also don't explicitly remove the kernel image located in binaries as
we're already removing that dir.

Makefile

index ed8c2610e65b4aedf93bdf7da5edf44658e927b9..065378766f448cf659adc331929d76d009fb1fa4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -402,9 +402,8 @@ distclean:
 ifeq ($(DL_DIR),$(BASE_DIR)/dl)
        rm -rf $(DL_DIR)
 endif
-       rm -rf $(BUILD_DIR) $(PROJECT_BUILD_DIR) $(BINARIES_DIR) \
-       $(LINUX_KERNEL) $(BASE_DIR)/include \
-               .config.cmd
+       rm -rf $(TOOL_BUILD_DIR) $(BUILD_DIR) $(PROJECT_BUILD_DIR) $(BINARIES_DIR) \
+       .config.cmd
        $(MAKE) -C $(CONFIG) clean
 
 sourceball: