mongoose: drop unused openssl linker flags
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 21 Sep 2017 21:21:37 +0000 (23:21 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 22 Sep 2017 16:22:12 +0000 (18:22 +0200)
No linking is done since the package was reworked for v6.x in commit
9860746ff (mongoose: bump to version 6.1), so drop LDFLAGS and the list of
libraries to link against.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mongoose/mongoose.mk

index 702342b3b1f4dfb1408bd3efb6bc20f39333f619..2705bdd4a52b78113d2c877edd5308f82efc96e6 100644 (file)
@@ -10,12 +10,11 @@ MONGOOSE_LICENSE = GPL-2.0
 MONGOOSE_LICENSE_FILES = LICENSE
 MONGOOSE_INSTALL_STAGING = YES
 
-MONGOOSE_CFLAGS = $(TARGET_CFLAGS) $(TARGET_LDFLAGS)
+MONGOOSE_CFLAGS = $(TARGET_CFLAGS)
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 MONGOOSE_DEPENDENCIES += openssl
-# directly linked
-MONGOOSE_CFLAGS += -DNS_ENABLE_SSL -lssl -lcrypto -lz
+MONGOOSE_CFLAGS += -DNS_ENABLE_SSL
 endif
 
 define MONGOOSE_BUILD_CMDS