ghostscript: set correct font path on target
authorThomas Ehrhardt <e.thomas@gmx.de>
Wed, 25 Jul 2018 11:46:28 +0000 (06:46 -0500)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 28 Jul 2018 21:57:10 +0000 (23:57 +0200)
GHOSTSCRIPT_FONTS_TARGET_DIR is set to $(TARGET_DIR)/usr/share/fonts/gs
in ghostscript-fonts.mk. If we pass this full path to ghostscript, it
will look for fonts in $(TARGET_DIR), which doesn't exist on the
target.

Instead of /usr/share/fonts/gs, use /usr/share/fonts so ghostscript can
also access other fonts than the ones installed by ghostscript-fonts.

Signed-off-by: Thomas Ehrhardt <tehrhardt@innovaphone.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/ghostscript/ghostscript.mk

index fcfb8d70582ed7fd3fe828ad0f3ab2465a6aa9f7..8ea6610be507701c4759745b680c8f204603e7d5 100644 (file)
@@ -40,7 +40,7 @@ GHOSTSCRIPT_CONF_OPTS = \
        --disable-compile-inits \
        --disable-cups \
        --enable-fontconfig \
-       --with-fontpath=$(GHOSTSCRIPT_FONTS_TARGET_DIR) \
+       --with-fontpath=/usr/share/fonts \
        --enable-freetype \
        --disable-gtk \
        --without-jbig2dec \