procps-ng: fix build without wide character support
authorBaruch Siach <baruch@tkos.co.il>
Fri, 27 Apr 2018 04:40:32 +0000 (07:40 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 27 Apr 2018 20:25:51 +0000 (22:25 +0200)
Define OFF_XTRAWIDE to disable use of wchar API when the toolchain does
not support that.

Fixes:
http://autobuild.buildroot.net/results/b96/b96d29d64f455726a53a7adcfd3edd546346201c/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/procps-ng/procps-ng.mk

index a6cf774d7bd2aa1487516c6ff59458e1aae5416c..0d5ce9ddf085d3d69047ab55904e6760d1e7c575 100644 (file)
@@ -40,6 +40,10 @@ PROCPS_NG_CONF_OPTS += \
        --enable-watch8bit
 endif
 
+ifeq ($(BR2_USE_WCHAR),)
+PROCPS_NG_CONF_OPTS += CPPFLAGS=-DOFF_XTRAWIDE
+endif
+
 # numa support requires libdl, so explicitly disable it when
 # BR2_STATIC_LIBS=y
 ifeq ($(BR2_STATIC_LIBS),y)