uboot: Introduce BR2_TARGET_UBOOT_FORMAT_DTB_IMX
authorFabio Estevam <festevam@gmail.com>
Thu, 5 Jul 2018 19:24:29 +0000 (16:24 -0300)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 7 Jul 2018 21:52:02 +0000 (23:52 +0200)
Some i.MX boards which use device tree to describe the hardware
for U-Boot generate a u-boot-dtb.imx binary.

Introduce the BR2_TARGET_UBOOT_FORMAT_DTB_IMX option to
handle such case.

Signed-off-by: Fabio Estevam <festevam@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
boot/uboot/Config.in
boot/uboot/uboot.mk

index 482711ca6410d56252fcd06780b0c0d161658928..7f8291abe894f87e1caf1ccf1d29172dd1772167 100644 (file)
@@ -190,6 +190,9 @@ config BR2_TARGET_UBOOT_FORMAT_DTB_BIN
 config BR2_TARGET_UBOOT_FORMAT_DTB_IMG
        bool "u-boot-dtb.img"
 
+config BR2_TARGET_UBOOT_FORMAT_DTB_IMX
+       bool "u-boot-dtb.imx"
+
 config BR2_TARGET_UBOOT_FORMAT_IMG
        bool "u-boot.img"
 
index 6ef275e8423c51e0d1450cdcb31160945f477b88..bf227f28934fb026e31577f94b877fb7d2953a53 100644 (file)
@@ -70,6 +70,11 @@ UBOOT_BINS += u-boot-dtb.img
 UBOOT_MAKE_TARGET += u-boot-dtb.img
 endif
 
+ifeq ($(BR2_TARGET_UBOOT_FORMAT_DTB_IMX),y)
+UBOOT_BINS += u-boot-dtb.imx
+UBOOT_MAKE_TARGET += u-boot-dtb.imx
+endif
+
 ifeq ($(BR2_TARGET_UBOOT_FORMAT_DTB_BIN),y)
 UBOOT_BINS += u-boot-dtb.bin
 UBOOT_MAKE_TARGET += u-boot-dtb.bin