pdinoto writes:
authorEric Andersen <andersen@codepoet.org>
Fri, 25 Feb 2005 02:38:28 +0000 (02:38 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 25 Feb 2005 02:38:28 +0000 (02:38 -0000)
This patch adds an option in GCC config to compile Objective-C language support
in the toolchain. It is disabled by default, so it is not intrusive.

toolchain/gcc/Config.in
toolchain/gcc/gcc-uclibc-3.x.mk

index 9403aba278a7fbf1441fdb832f632012c4c76986..3bce26efd1decd2989d9de7df9c1814cf6b92246 100644 (file)
@@ -74,3 +74,10 @@ config BR2_INSTALL_LIBGCJ
        depends on BR2_INSTALL_LIBSTDCPP
        help
            Build/install java compiler and libgcj?
+
+config BR2_INSTALL_OBJC
+       bool "Build/install Objective-C compiler and runtime?"
+       default n
+       help
+           Build/install Objective-C compiler and runtime?
+
index 3457b4a69bf06d7fca33cd918881dbc11d423b1d..0e400c2360b3961d564ea1a3b4e1a51b4dce2b58 100644 (file)
@@ -49,6 +49,10 @@ TARGET_LANGUAGES:=c
 endif
 endif
 
+ifeq ($(BR2_INSTALL_OBJC),y)
+TARGET_LANGUAGES:=$(TARGET_LANGUAGES),objc
+endif
+
 #############################################################
 #
 # build the first pass gcc compiler