package/openjpeg: New package openjpeg 1.5.2
authorOlivier Schonken <olivier.schonken@gmail.com>
Sun, 22 Mar 2015 21:12:49 +0000 (23:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 4 Apr 2015 09:10:22 +0000 (11:10 +0200)
This package is needed by Poppler.

[Thomas:
 - fix download location, which was incorrect.
 - add dependency on host-pkgconf, since the configure.ac script uses
   PKG_CHECK_MODULES and we're doing an autoreconf.
 - add optional dependencies on libpng, tiff and lcms2, so that they
   are explicit instead of automatically detected.]

Signed-off-by: Olivier Schonken <olivier.schonken@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/openjpeg/Config.in [new file with mode: 0644]
package/openjpeg/openjpeg.hash [new file with mode: 0644]
package/openjpeg/openjpeg.mk [new file with mode: 0644]

index ee4d476bd44a6f604485eeaf81eca54ffc177939..3f670f3e8dd7675cb1827f4d3e3a2f458cc1636a 100644 (file)
@@ -757,6 +757,7 @@ menu "Graphics"
        source "package/libvips/Config.in"
        source "package/opencv/Config.in"
        source "package/opengl/Config.in"
+       source "package/openjpeg/Config.in"
        source "package/pango/Config.in"
        source "package/pixman/Config.in"
        source "package/poppler/Config.in"
diff --git a/package/openjpeg/Config.in b/package/openjpeg/Config.in
new file mode 100644 (file)
index 0000000..005d298
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_OPENJPEG
+       bool "openjpeg"
+       help
+         The OpenJPEG library is an open-source JPEG 2000 codec
+         written in C.
+
+          http://www.openjpeg.org
diff --git a/package/openjpeg/openjpeg.hash b/package/openjpeg/openjpeg.hash
new file mode 100644 (file)
index 0000000..a8695c1
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256 15df7b194a5d8dba0052cd21c17a4dc761149a770a907d73fffb972078c28a87  openjpeg-1.5.2.tar.gz
diff --git a/package/openjpeg/openjpeg.mk b/package/openjpeg/openjpeg.mk
new file mode 100644 (file)
index 0000000..c613ba8
--- /dev/null
@@ -0,0 +1,38 @@
+################################################################################
+#
+# openjpeg
+#
+################################################################################
+
+OPENJPEG_VERSION = 1.5.2
+OPENJPEG_SITE = http://downloads.sourceforge.net/project/openjpeg.mirror/$(OPENJPEG_VERSION)
+OPENJPEG_LICENSE = BSD-2c
+OPENJPEG_LICENSE_FILES = LICENSE
+# tarball does not contain the generated files
+OPENJPEG_AUTORECONF = YES
+OPENJPEG_INSTALL_STAGING = YES
+OPENJPEG_DEPENDENCIES = host-pkgconf
+OPENJPEG_CONF_OPTS = --disable-lcms1
+
+ifeq ($(BR2_PACKAGE_LIBPNG),y)
+OPENJPEG_DEPENDENCIES += libpng
+OPENJPEG_CONF_OPTS += --enable-png
+else
+OPENJPEG_CONF_OPTS += --disable-png
+endif
+
+ifeq ($(BR2_PACKAGE_TIFF),y)
+OPENJPEG_DEPENDENCIES += tiff
+OPENJPEG_CONF_OPTS += --enable-tiff
+else
+OPENJPEG_CONF_OPTS += --disable-tiff
+endif
+
+ifeq ($(BR2_PACKAGE_LCMS2),y)
+OPENJPEG_DEPENDENCIES += lcms2
+OPENJPEG_CONF_OPTS += --enable-lcms2
+else
+OPENJPEG_CONF_OPTS += --disable-lcms2
+endif
+
+$(eval $(autotools-package))