gvfs: fix activation of http/dav backend
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 13 Oct 2018 15:06:06 +0000 (17:06 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 14 Oct 2018 07:59:12 +0000 (09:59 +0200)
Since gvfs version 1.2.3, http/dav backend needs libxml2:
https://gitlab.gnome.org/GNOME/gvfs/commit/2ef5b4192f95f9205204215aec33787641608e58

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gvfs/gvfs.mk

index 7110e39083af7f41d16abae31c51436bac344fd9..e272d5c1dc3b7c9c38de1d867bb6621db443fe0a 100644 (file)
@@ -95,8 +95,8 @@ else
 GVFS_CONF_OPTS += --disable-nfs
 endif
 
-ifeq ($(BR2_PACKAGE_LIBSOUP),y)
-GVFS_DEPENDENCIES += libsoup
+ifeq ($(BR2_PACKAGE_LIBSOUP)$(BR2_PACKAGE_LIBXML2),yy)
+GVFS_DEPENDENCIES += libsoup libxml2
 GVFS_CONF_OPTS += --enable-http
 else
 GVFS_CONF_OPTS += --disable-http