tcpreplay: fix linking when libpcap is built with canusb support
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 27 Jun 2012 07:42:33 +0000 (09:42 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 27 Jun 2012 07:42:33 +0000 (09:42 +0200)
Fixes http://autobuild.buildroot.net/results/f3cee3df639a8ecf0f7f81ca33efee4e040c76ff

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/tcpreplay/tcpreplay.mk

index 72abade5f686b8539743949f5b87d20148d967cd..4a72266046cddfd1398ed0aa944f96eba7524911 100644 (file)
@@ -11,5 +11,9 @@ TCPREPLAY_CONF_OPT = --with-libpcap=$(STAGING_DIR)/usr
 TCPREPLAY_AUTORECONF = YES
 TCPREPLAY_DEPENDENCIES = libpcap
 
+# libpcap may depend on symbols in libusb as well
+TCPREPLAY_LIBS = -lpcap $(if $(BR2_PACKAGE_LIBUSB),-lusb-1.0)
+TCPREPLAY_CONF_ENV += ac_cv_search_pcap_close='$(TCPREPLAY_LIBS)'
+
 $(eval $(call AUTOTARGETS))