crosstool-ng: use uClibc 0.9.33.1 / NPTL by default
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 9 May 2012 09:17:07 +0000 (11:17 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 9 May 2012 09:17:07 +0000 (11:17 +0200)
So we're in sync with the internal toolchain.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-crosstool-ng/Config.in
toolchain/toolchain-crosstool-ng/crosstool-ng.config-uClibc
toolchain/toolchain-crosstool-ng/crosstool-ng.mk

index 2d1e801c40fce8591eb93799527dfff2a34836d9..35ea2b1c813aceed0ad8c9f9fa0e3ea71add53a1 100644 (file)
@@ -99,11 +99,7 @@ config BR2_TOOLCHAIN_CTNG_CXX
 
 choice
        prompt "Thread library implementation"
-       default BR2_TOOLCHAIN_CTNG_THREADS_PTHREADS_OLD \
-               if BR2_TOOLCHAIN_CTNG_uClibc
-       default BR2_TOOLCHAIN_CTNG_THREADS_NPTL         \
-               if BR2_TOOLCHAIN_CTNG_eglibc ||         \
-                  BR2_TOOLCHAIN_CTNG_glibc
+       default BR2_TOOLCHAIN_CTNG_THREADS_NPTL
        help
          Enable thread support and select thread implementation. With
          glibc, thread support is mandatory but several
@@ -129,8 +125,6 @@ choice
        config BR2_TOOLCHAIN_CTNG_THREADS_NPTL
                bool "Native POSIX Threading (NPTL)"
                select BR2_TOOLCHAIN_HAS_THREADS
-               depends on BR2_TOOLCHAIN_CTNG_eglibc || \
-                          BR2_TOOLCHAIN_CTNG_glibc
 endchoice
 
 endif # BR2_TOOLCHAIN_CTNG
index 13b30d95feb0cc89057ddeb0d7a809338b42239d..c1150965a9845ee3ed57dfc969af3a6c44adc9cc 100644 (file)
@@ -322,13 +322,13 @@ CT_CC_GCC_LDBL_128=m
 # C-library
 #
 CT_LIBC="uClibc"
-CT_LIBC_VERSION="0.9.32"
+CT_LIBC_VERSION="0.9.33.1"
 CT_LIBC_uClibc=y
 CT_LIBC_uClibc_AVAILABLE=y
-# CT_LIBC_UCLIBC_V_0_9_33_1 is not set
+# CT_LIBC_UCLIBC_V_0_9_33_1=y
 # CT_LIBC_UCLIBC_V_0_9_33 is not set
 # CT_LIBC_UCLIBC_V_0_9_32_1 is not set
-CT_LIBC_UCLIBC_V_0_9_32=y
+# CT_LIBC_UCLIBC_V_0_9_32 is not set
 # CT_LIBC_UCLIBC_V_0_9_30_3 is not set
 # CT_LIBC_UCLIBC_V_0_9_30_2 is not set
 # CT_LIBC_UCLIBC_V_0_9_30_1 is not set
@@ -355,8 +355,8 @@ CT_THREADS="linuxthreads"
 #
 # Common C library options
 #
-# CT_THREADS_NPTL is not set
-CT_THREADS_LINUXTHREADS=y
+CT_THREADS_NPTL=y
+# CT_THREADS_LINUXTHREADS is not set
 # CT_THREADS_NONE is not set
 CT_LIBC_XLDD=y
 
index eb9e9639f668fa367fe9907b3dafd615bfc82d9d..25d2a169688c5e9f833b13fef4bdc6f87b5dba49 100644 (file)
@@ -10,7 +10,7 @@
 
 CTNG_DIR := $(BUILD_DIR)/build-toolchain
 
-CTNG_UCLIBC_CONFIG_FILE := $(TOPDIR)/toolchain/uClibc/uClibc-0.9.32.config
+CTNG_UCLIBC_CONFIG_FILE := $(TOPDIR)/toolchain/uClibc/uClibc-0.9.33.config
 CTNG_CONFIG_FILE:=$(call qstrip,$(BR2_TOOLCHAIN_CTNG_CONFIG))
 
 # Hack! ct-ng is in fact a Makefile script. As such, it accepts all