mpd: enable cdio-paranoia support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 28 Apr 2018 16:51:36 +0000 (18:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 28 Apr 2018 16:59:06 +0000 (18:59 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpd/Config.in
package/mpd/mpd.mk

index 831e4ab0d7296f4931f9f05c3c193f6853022bf6..857f2124774abee406d20e5b2e90f50a697de028 100644 (file)
@@ -174,6 +174,12 @@ config BR2_PACKAGE_MPD_TWOLAME
 
 comment "Input plugins"
 
+config BR2_PACKAGE_MPD_CDIO_PARANOIA
+       bool "cdio-paranoia"
+       select BR2_PACKAGE_LIBCDIO_PARANOIA
+       help
+         Enable cdio-paranoia support.
+
 config BR2_PACKAGE_MPD_CURL
        bool "curl"
        select BR2_PACKAGE_LIBCURL
index 64471d4da5e902d31bcb51004e253524e4978ef0..d41ffe1571bf9cf89da115ff8bcd06a0784d0e2e 100644 (file)
@@ -59,6 +59,13 @@ else
 MPD_CONF_OPTS += --disable-bzip2
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_CDIO_PARANOIA),y)
+MPD_DEPENDENCIES += libcdio-paranoia
+MPD_CONF_OPTS += --enable-cdio-paranoia
+else
+MPD_CONF_OPTS += --disable-cdio-paranoia
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_CURL),y)
 MPD_DEPENDENCIES += libcurl
 MPD_CONF_OPTS += --enable-curl