package/tinyssh: new package
authorVadim Kochan <vadim4j@gmail.com>
Mon, 19 Aug 2019 23:44:13 +0000 (02:44 +0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 1 Jan 2020 10:59:42 +0000 (11:59 +0100)
TinySSH is a minimalistic SSH server which implements only a subset of
SSHv2 features.

Might be useful for small systems.

Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
[yann.morin.1998@free.fr:
  - add missing licence file, as noticed by Giulio
  - update the version to bring two fixes
  - update hash file accordingly (version and licence file)
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
DEVELOPERS
package/Config.in
package/tinyssh/Config.in [new file with mode: 0644]
package/tinyssh/tinyssh.hash [new file with mode: 0644]
package/tinyssh/tinyssh.mk [new file with mode: 0644]

index 27bedad48c063fdc62dade4eaef8c7010f6a595b..90941dd4c839a4eaa380ae44d109297cd5c7f977 100644 (file)
@@ -2462,6 +2462,7 @@ F:        package/tstools/
 N:     Vadim Kochan <vadim4j@gmail.com>
 F:     package/brcm-patchram-plus/
 F:     package/gettext-tiny/
+F:     package/tinyssh/
 
 N:     Valentin Korenblit <valentinkorenblit@gmail.com>
 F:     package/clang/
index 05a4e87ae7bb2dd106d81db331cbd2d8c792951b..894284c65060009781bbe2b3c94f563a54f097ab 100644 (file)
@@ -2149,6 +2149,7 @@ endif
        source "package/thttpd/Config.in"
        source "package/tinc/Config.in"
        source "package/tinyhttpd/Config.in"
+       source "package/tinyssh/Config.in"
        source "package/tor/Config.in"
        source "package/traceroute/Config.in"
        source "package/transmission/Config.in"
diff --git a/package/tinyssh/Config.in b/package/tinyssh/Config.in
new file mode 100644 (file)
index 0000000..da19d2d
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_TINYSSH
+       bool "tinyssh"
+       depends on BR2_USE_MMU # fork()
+       help
+         TinySSH is a minimalistic SSH server which implements only
+         a subset of SSHv2 features.
+
+         https://tinyssh.org
diff --git a/package/tinyssh/tinyssh.hash b/package/tinyssh/tinyssh.hash
new file mode 100644 (file)
index 0000000..99ee4af
--- /dev/null
@@ -0,0 +1,3 @@
+# locally computed
+sha256  65a7dc785861a09399419a1e7c42cddf66f32dc233a33277327b11f1bd8a772c  tinyssh-7e2b4025bf3a2dae4c6617e3eb39df4bcde37454.tar.gz
+sha256  b5dc19477e29f4111e1c16cd89ec0782f5a07b1a30e3bdb7c155425b81b12c46  LICENCE
diff --git a/package/tinyssh/tinyssh.mk b/package/tinyssh/tinyssh.mk
new file mode 100644 (file)
index 0000000..6f22be6
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# tinyssh
+#
+################################################################################
+
+TINYSSH_VERSION = 7e2b4025bf3a2dae4c6617e3eb39df4bcde37454
+TINYSSH_SITE = $(call github,janmojzis,tinyssh,$(TINYSSH_VERSION))
+TINYSSH_LICENSE = Public Domain, CC0-1.0
+TINYSSH_LICENSE_FILES = LICENCE
+
+define TINYSSH_BUILD_CMDS
+       $(TARGET_MAKE_ENV) CC="$(TARGET_CC)" $(MAKE) -C $(@D) cross-compile
+endef
+
+define TINYSSH_INSTALL_TARGET_CMDS
+       $(MAKE) DESTDIR="$(TARGET_DIR)" -C $(@D) install
+endef
+
+$(eval $(generic-package))