ncurses: use $(HOST_MAKE_ENV) when calling $(MAKE)
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Mon, 17 Oct 2016 16:05:57 +0000 (13:05 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Oct 2016 13:19:24 +0000 (15:19 +0200)
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ncurses/ncurses.mk

index 9555f1ed664fd328a0f681a072fd48cf236cea29..343909fe3f7110b3a365931f966ba87f6928a858 100644 (file)
@@ -169,8 +169,8 @@ endef # NCURSES_INSTALL_TARGET_CMDS
 # ourselves, and use that during installation.
 #
 define HOST_NCURSES_BUILD_CMDS
-       $(MAKE1) -C $(@D) sources
-       $(MAKE) -C $(@D)/progs tic
+       $(HOST_MAKE_ENV) $(MAKE1) -C $(@D) sources
+       $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/progs tic
 endef
 
 HOST_NCURSES_CONF_OPTS = \