package/python-kiwisolver: new package
authorEsben Haabendal <esben@geanix.com>
Tue, 17 Sep 2019 08:50:33 +0000 (10:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 19 Sep 2019 21:31:04 +0000 (23:31 +0200)
Signed-off-by: Esben Haabendal <esben@geanix.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-kiwisolver/Config.in [new file with mode: 0644]
package/python-kiwisolver/python-kiwisolver.hash [new file with mode: 0644]
package/python-kiwisolver/python-kiwisolver.mk [new file with mode: 0644]

index 1557608356cc93b284cf7e141bfedcab931a7cd5..67a0fef0886de54b4b41f698d010640b5eaf4a57 100644 (file)
@@ -722,6 +722,7 @@ F:  package/szip/
 
 N:     Esben Haabendal <esben@haabendal.dk>
 F:     boot/gummiboot/
+F:     package/python-kiwisolver/
 
 N:     Etienne Carriere <etienne.carriere@linaro.org>
 F:     boot/optee-os/
index 1026dd7c16aa816ee523f4131631f1e7417c2bb0..dbf297f4df398c7b06c5145d2a63af87447a630f 100644 (file)
@@ -936,6 +936,7 @@ menu "External python modules"
        source "package/python-jsonmodels/Config.in"
        source "package/python-jsonschema/Config.in"
        source "package/python-keyring/Config.in"
+       source "package/python-kiwisolver/Config.in"
        source "package/python-libconfig/Config.in"
        source "package/python-libusb1/Config.in"
        source "package/python-lmdb/Config.in"
diff --git a/package/python-kiwisolver/Config.in b/package/python-kiwisolver/Config.in
new file mode 100644 (file)
index 0000000..33727ba
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_PYTHON_KIWISOLVER
+       bool "python-kiwisolver"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         Kiwi is an efficient C++ implementation of the Cassowary
+         constraint solving algorithm. Kiwi is an implementation of
+         the algorithm based on the seminal Cassowary paper. It is
+         not a refactoring of the original C++ solver. Kiwi has been
+         designed from the ground up to be lightweight and fast. Kiwi
+         ranges from 10x to 500x faster than the original Cassowary
+         solver with typical use cases gaining a 40x
+         improvement. Memory savings are consistently > 5x.
+
+         https://github.com/nucleic/kiwi
+
+comment "python-kiwisolver needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/python-kiwisolver/python-kiwisolver.hash b/package/python-kiwisolver/python-kiwisolver.hash
new file mode 100644 (file)
index 0000000..9cdb270
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 48168c0ace18319c649e31907f6d8586f648e503560f506f128798b99393bcdb  python-kiwisolver-1.1.0.tar.gz
+sha256 95c32f73d43fa54d8146badbcbd73b83acb7fa2cc81a7cef7784b3cd33b146a0  LICENSE
diff --git a/package/python-kiwisolver/python-kiwisolver.mk b/package/python-kiwisolver/python-kiwisolver.mk
new file mode 100644 (file)
index 0000000..2b99803
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-kiwisolver
+#
+################################################################################
+
+PYTHON_KIWISOLVER_VERSION = 1.1.0
+PYTHON_KIWISOLVER_SITE = $(call github,nucleic,kiwi,$(PYTHON_KIWISOLVER_VERSION))
+PYTHON_KIWISOLVER_LICENSE = BSD-3-Clause
+PYTHON_KIWISOLVER_LICENSE_FILES = LICENSE
+PYTHON_KIWISOLVER_SETUP_TYPE = setuptools
+
+$(eval $(python-package))